Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003
    Location
    The Netherlands
    Posts
    149

    Unanswered: not correct in db

    Hello people, i'm inserting an in my database through a sql-script. When I later on select this value, it only shows d instead of . Does anyone know how i can change this. I used different charactersets and also charset=none in the connection string as a connection parameter, but i don't think this is it.

    thanks beforehand.

    Coen Dunnink
    The Netherlands

  2. #2
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    What is the OS of your ASE server
    What is its sort order and character set (sp_helpsort)
    What is the OS of your client (Win ?)

    you probably must use -J option

  3. #3
    Join Date
    Jan 2003
    Location
    The Netherlands
    Posts
    149

    already have a solution

    After my conversion from sybase 6 to 9 I had to explicitly tell the connection which charset I wanted to use. Our db has charset cp850 and when I connect with the newly created sybase 9 db, the characterset was automatically set to cp1252(ansii). Now I put CS=cp850 in my connectionstring and everything is solved. But thanks anywayz

    greetings Coen

  4. #4
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    Your're using Sybase Anywhere and not Sybase ASE.
    Why are you using cp850 and not LATIN1 (iso1), the native Win collation sequence ? Your problem is probably coming from a bad conversion between client and server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •