Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2003
    Location
    FRANCE
    Posts
    393

    Unanswered: sp_addserver 'local'

    When I run this in the QA

    SELECT @@SERVERNAME

    i get

    MachineName\InstanceName


    why don't these commands work ?

    sp_dropserver 'MachineName\InstanceName'
    sp_addserver 'MachineName\InstanceName,'local'

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    I have a similar problem, but I have not yet been able to cycle the SQL service on that box, yet (only been 4 months). I believe @@servername will update itself after the service comes back up.

    Oh, and remember to update your sysjobs table, because all of those jobs are "owned by another server". You will not be able to update/delete them at all, until you update the server names in the sysjobs table.

  3. #3
    Join Date
    Nov 2003
    Location
    FRANCE
    Posts
    393
    I'm trying to get a local-local-LOCAL server

    for example with SQL Server 7 I could connect to my server with
    (local)

    since I've got SQL Server 2K I've got to specify instead
    SCG59730\Mercure
    that corresponds to ComputerName\InstanceName

    I'm trying ways to connect again with the term < (local) >

  4. #4
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    I assume you already tried (local)\instancename? I can not try it out here, without a few re-installs, re-boots, etc..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •