Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2004
    Location
    New York City
    Posts
    3

    Unanswered: Setting up MSDE on XP Professional at home

    Setting up MSDE on XP Professional at home as sole machine user. Consistently get error System.Data.SqlClient.sqlError “Login Failed for user ‘sa’. Reason: Not associated with a trusted SQL Server connection”.

    Think this is because with SQL Server security, user must provide enough information, usually a login name and a password, in order to successfully log onto server.

    How to get user established in sql database as trusted user?

    Thanks. Seek_To_know

  2. #2
    Join Date
    Nov 2003
    Posts
    91
    You really should use Enterprise Manager to change from 'Windows Authen. Mode' to
    'Mixed Mode', but if you want to use regedit you can change it yourself:
    If you do not have a copy of Microsoft Enterprise Manager, here is how to Change Authentication for SQL Server or MSDE:

    Look for a Windows registry subkey similar to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\LoginMode.
    (This subkey name is from my machine.
    Your subkey name will depend on what instances of MSDE and SQL Server you have installed.)

    Values
    1: Only Windows Authentication
    2: Mixed Mode Authentication

    I found this key on one of my machines at:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\VSDOTNET\MSSQLServer\LoginMode.

  3. #3
    Join Date
    Feb 2004
    Location
    New York City
    Posts
    3
    Thanks for the quick response. Is it really necessary to change to mixed-mode? I’m not using SQL Server but MSDE and I think that it can work with 'Windows Authen. Mode'

    I appreciate any guidance.

    Seek_To_Know

  4. #4
    Join Date
    Nov 2003
    Posts
    91
    I don't know if it is necessary, but it worked for me.
    I wasn't able to get MSDE to work until I made this change
    to the registry.

    MSDE *IS* MS SQL Server, except it had the GUI portion stripped out
    and the license was changed, and MS crippled it so it wont handle large databases.

  5. #5
    Join Date
    Feb 2004
    Location
    New York City
    Posts
    3
    I’ll give it a try later (at work now).

    Be well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •