My perl DBD module is compiled using 8.1.7 binaries. I have installed a 9.2.0 database on the same Sun solaris 2.6 box.

When I run the same scripts against the 9.2.0 database it fails with the following error...


If I recompile the DBD module with the 9.2.0 database the scripts will run fine.

I have multiple 8.1.7 databases on this same server? how can I run the same scripts using the same perl binaries on this server for both oracle versions?

thanks robert