Results 1 to 2 of 2

Thread: Update & oledb

  1. #1
    Join Date
    Feb 2004
    Posts
    1

    Unanswered: Update & oledb

    Dear gurus,

    My problem: I have developed an application based on sqloledb to access a SQLserver application.

    One of the operations is to update certain column of a certain table. This works fine. But with a specific catalog (database) of a specific customer the update hangs for ever on the execution of that sql sentence. Size of the mdb file is around 1 Gb.
    The funny thing is that if I execute the same sql sentence (same record and same catalog) from the Query Analyzer ( that I belive it uses odbc ) the operation is done.
    The update sql sentence does an update on a non-indexed column with the criteria ( where ...) using a index column (non-clustered)
    I have tried the sqlmaint to rebuild indexes and check integrity and no special error report is given.

    Also another funny behaviour is that if I stop and I restart sqlserver, the update of that specific record fails, but it continues of the following records to be updated.

    This is not executed inside a transaction. Candidate records to be updated are stored in memory (maximum 1000), and one by one are updated.

    Does anyone know an specific tool to integrity or to monitor what is going on?
    I have tried the profiler , what can I monitor to detect this lock?

    Best regards,
    Jose

  2. #2
    Join Date
    Nov 2003
    Location
    FRANCE
    Posts
    393

    Re: Update & oledb

    (note : I'm not a good guru)


    Maybe your table is locked in some way ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •