Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2004
    Posts
    8

    Unanswered: trouble installing sql server

    Hello,

    I have run sql server 2000 and analysis manager on my laptop for a few months with no probs. On Monday I tried to connect to my computer server from sql server ent manager and it said "no datasource found." and something else about MS ODBC drivers being invalid. Analysis services still worked fine. I tired to connect and add servers and it just would not recognise anything so became software I could not use at all. I then uninstalled all sql server products on my computer. I thought a fresh reinstall would do the job. However now when I try to install sql server I get an error in the installation. It says that it cannot connect to the datasource and installation fails. It tells me to look in a sqlstp log and the bottom of this log is below

    15:50:25 Begin Action: DialogShowSdUninstall
    15:50:28 ShowDlgUninstall returned : 1
    15:50:28 End Action DialogShowSdUninstall
    15:50:28 Dialog 0x80000000 returned: 1
    15:50:28 End Action ShowDialogsHlpr
    15:50:28 ShowDialogsGetDialog returned: nCurrent=0x0,index=0
    15:50:28 End Action ShowDialogs
    15:50:29 Action CleanUpInstall:
    15:50:29 StatsGenerate returned: 2
    15:50:29 StatsGenerate (0xc0200805,0x2,0xf000000,0x400,1033,303,0x2,0x1,0 ,0,0
    15:50:29 StatsGenerate -1,rj)
    15:50:29 Installation Failed.

    I havent shown the rest of the log because there is a lot of it. If needed I can copy in the rest.

    The rest of the installation up to this point seems fine. HOwever it doesnt install the unistall files so I cannot uninstall SQL Server now. There is 105 MB of the program on my computer which I can only delete although I havent done this yet.

    Why wont sql server let me install? It is a really annoying problem because it worked fine last Friday and then on Monday it went wrong and I cannot remember doing anything to make this happen. All MS updates are up-to-date. Any help is greatly appreciated

    Thanks
    Richard

  2. #2
    Join Date
    Feb 2004
    Posts
    8

    fixed

    PROBLEM SOLVED!

    The transaction log when I got the error said something about ODBC drivers so I went to the ms web site and downloaded the lastest MDAC drivers

    (http://www.microsoft.com/downloads/d...DisplayLang=en)

    I then tried the installation and it worked. I guess some of my original driver files must have been corrupt

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •