Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2004
    Location
    NJ
    Posts
    37

    Unanswered: Oracle Management Server Problem

    I am having an issue with my Oracle Management Server. I originally had a database on one of the comps then switched it over to another server and reloaded the data. I set up the OMS on the old computer but when i tried to set it up on the new server i tried to log in with the default name/password: sysman/oem_temp and it won't log in. So i am not sure if someone logged in and set a password. I asked the one other person that i thought might have and he hasn't touched the box. So my question is does Oracle give a fallback account so i can get into the OMS to set it up? Like a reset or something? Or would i have to reinstall everything and reload the database? Any help you guys can offer i would appreciate, i would prefer to find an option that didn't involve having to reinstall everything.

    PS i did a search on in the forums and google and didn't come up with anything so i figured i would ask here.

    thanks,
    Evan

  2. #2
    Join Date
    Jan 2004
    Location
    Scottsdale, AZ
    Posts
    106
    Define "won't log in". Usually posting the error message, os, and database version can help the gurus gaze into their crystal balls.
    "Take Control!
    Make The Choice!
    Accept The Consequences!
    Deal With The Results! "

  3. #3
    Join Date
    Feb 2004
    Location
    NJ
    Posts
    37
    Sorry about that. I am running Oracle 9 on a Windows server 2003 box. The error message is:
    Unable to connect to management server. Please check to make sure all the information you have entered is correct.

    Something to that effect, i am not in front of the server right now.

  4. #4
    Join Date
    Feb 2004
    Location
    NJ
    Posts
    37
    anyone?

  5. #5
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    Try this ... From documentation

    If you forget your SYSMAN password and need to reset it to oem_temp, follow the instructions below:

    You must first be connected to the Management Server repository (via SQL*Plus) before using the reset_sysman() procedure.

    Start SQL*Plus from the command line by typing:

    sqlplus


    When you are prompted for the connection information, type:

    <emrepository>/<emrepository-pwd>@<em-repository>


    to connect to the database.

    For example:

    mynode/mypassword@mynode.world


    since the default repository name is the hostname.

    Then type:

    execute smp_maintenance.reset_sysman();


    HTH
    Gregg

  6. #6
    Join Date
    Feb 2004
    Location
    NJ
    Posts
    37
    alright i tried that and i got an error with the username. But aside from that i tried several different things and was eventually able to create the management server that i wanted and changed the default login, but i ran into an issue. I just want to make sure that i am doing this correct. I previously set up my database on another server and configured that computer to be a management server, but i don't recall exactly how i did it, and that machine is now going to be used for a different project so i can't use that one as the management server anyone. That is why i tried to install the management server on this new server.

    but when i logged into the management server there was no database tab that listed the database that i have been using, this shows up on the other computer that i set up. I tried to add a database while logged into the OMS but it is not letting me. There is a good chance that i am doing something wrong because i never learned the in's and outs of oracle, i just kept trying until i got what i needed to work. So my question is how do i add my database to the OMS. Any help would be appreciated

  7. #7
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    1. Ensure the management server is running (service).
    2. Under the Navigator tab, discover nodes

    HTH
    Gregg

  8. #8
    Join Date
    Feb 2004
    Location
    NJ
    Posts
    37
    Management server is running. And i already did what you mentioned to discover the nodes. But that does not show me the actual database with schema, security... and all that other stuff like when you enter a database through the Enterprise Manager. I appologize that these are probably stupid questions.

    I am not sure if this is part of the problem i created a new repository called oemrep and set all the stuff up for that. The populated database that i would like to add to the Management Server has the service name: mapman. Then i go into enterprise manager > log into management server and I am able to log into mapman.blah.org but when i go into the configuration assistant and go to edit config it shows that it is referencing the user name:OEM_MAPMAN_OEMREP and the service: MAPMAN:1521:OEMREP. Maybe i just don't understand the relation between a database and the Management Server and how that works. I just remember that last time i set up the management server on the previous machine all i had to do was log in with the default name and password and everything was done, setting it up this time hasn't proved this easy. I have looked in various oracle reference books but haven't found anything to help me so far. Hopefully this explains my situation a little better and what i am having issues with, maybe someone can explain to me what i am doing wrong or how all the relations work

    thanks

  9. #9
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    Discover nodes will work if the agent is running on the db server. Once discover nodes comes back without anything, can you manual enter the service name ??? Do you have the entries for the database you are trying to connect to in TNSNAMES ??? ie, can you connect to the other database thru SQLPlus or TNSPING from the server you are currently on ?

    Gregg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •