Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2004
    Posts
    8

    Unanswered: .mb file corruption?

    Hi,

    I am trying to copy pictures (blob fields) from one table to another - however when I look at my table I get an 'invalid blob header' error message!

    Anyone know what I am doing wrong?

    Many thanks for any help.

  2. #2
    Join Date
    Oct 2003
    Posts
    107
    How are you doing it? Interactive, ObjectPAL or DOS/Windows.

  3. #3
    Join Date
    Feb 2004
    Posts
    8
    Soory, I should have said, I am using ObjectPAL

  4. #4
    Join Date
    Oct 2003
    Posts
    107
    I'd like to see the code, then perhaps I can spot what is happening. There is typically not a problem doing this; however there is a recommendation that the field length of your BLOB (graphic) field should always be 1, even though Paradox allows for greater sizes. I seem to remember that it was believed to cause problems, but I can't remember what type or under what circumstances. It might be worth a try to check that and change it if necessary.

  5. #5
    Join Date
    Oct 2003
    Posts
    706
    If you are dealing with "invalid blob header," I would assume that the MB file is corrupt. That the situation you are dealing with is abnormal.

    (Incidentally, the ChimneySweep product referred to in my signature is a Paradox oriented product, so "I know whereof I speak.")

    Unfortunately, I'm zeroing in on the word, header. If the header of a blob-file is damaged, then it's very likely that the file has been overwritten, or scribbled, or "ScanDisk found errors on this drive and fixed them all" ... and the data might be (ummmm, err, that is to say...) really gone.
    Last edited by sundialsvcs; 03-04-04 at 00:03.
    ChimneySweep(R): fast, automatic
    table repair at a click of the
    mouse! http://www.sundialservices.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •