Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2003
    Posts
    26

    Exclamation Unanswered: Full text catalog problem

    I have a database which has (god knows how) ended up with a Full text catalog which is believes is on the E: drive of the machine. The problem is that machine only has C: drive.

    If I try and rebuid the catalog (sp_fulltext_catalog 'documents','rebuild') I get an error saying that e:\... doesn't exist.

    If I try and drop the catalog (sp_fulltext_catalog 'documents', 'drop'), I can't because it contains a full-text index.

    If I try and drop remove the full text index from the table (sp_fulltext_table 'tbl_upload','drop'), I can't because Full-text catalog has been lost. Use sp_fulltext_catalog to rebuild and to repopulate it.

    HELP

    Does anybody know how to either drop it so that I can recreate it or how to update it so that it looks at a disk that the machine actually has?
    Nicky Jones

  2. #2
    Join Date
    Feb 2003
    Posts
    26

    Sorted!

    I updated the sysfulltextcatalogs table and set the path to null in there, this caused the system to then use the servers default path. I had tried to do this but was fooled by the fact that Enterprise manager claimed the table was empty whereas when I did a select from it from Query Analyser it returned the data.
    Nicky Jones

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •