Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2004
    Posts
    4

    Question Unanswered: SQL 17055 error and 17122 Description

    Hello !

    I have this problem :

    EVENT ID: 17055
    SOURCE: MSSQLServer
    CATEGORY: Kernel
    DESCRIPTION:
    17122 :
    initdata: Warning: Could not set working set size to 519104 KB.

    I have 1gb of memory.
    In the SQL server properties, I configure my memory with 512Kb not in dynamic but with determinated memory !
    I reserve 1024 for SQL request physical memory.

    Do you have any suggestions to resolve it ?
    My server reboot 3 times per day !!!!

    Thanks so lot !

    Jean-Philippe

  2. #2
    Join Date
    Sep 2002
    Location
    UK
    Posts
    5,171
    Provided Answers: 1

    Re: SQL 17055 error and 17122 Description

    Originally posted by filou01
    Hello !

    I have this problem :

    EVENT ID: 17055
    SOURCE: MSSQLServer
    CATEGORY: Kernel
    DESCRIPTION:
    17122 :
    initdata: Warning: Could not set working set size to 519104 KB.

    I have 1gb of memory.
    In the SQL server properties, I configure my memory with 512Kb not in dynamic but with determinated memory !
    I reserve 1024 for SQL request physical memory.

    Do you have any suggestions to resolve it ?
    My server reboot 3 times per day !!!!

    Thanks so lot !

    Jean-Philippe
    "SQL Server" and SQL are not the same thing!

  3. #3
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    I feel the originator refers to SQL Server only.

    Anyway, the warning message occurs because when you have AWE enabled. Set Working Set Size option is not supported when Address Windowing Extensions (AWE) option is enabled on your SQL Server 2000. In your case AWE is not in picture.

    The most possible causes for this is system is either low on memory or tempdb is near to its capacity.

    Take help of PERFMON to know the stats of h/w resources on SQL Server. SQL makes use of working sets in both. Check the file size on tempdb and check disk capacity where those located, check memory claimed by sql server and total system memory using task manager.

    BTW what is the level of Service pack on SQL & OS?
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  4. #4
    Join Date
    Mar 2004
    Posts
    4

    Exclamation Response

    Thanks for your reply !

    More informations :

    - SQL 2000 Fr Service pack 4
    - Windows 2000 Server fr
    - 1 Gb of memory !
    - I have a lot of place on the space disk ! (For SQL, datas and others) !

    - What is AWE ?
    - Is it necessary to disable it ?
    - If yes, how it's possible to disable it ?

    Thanks so lot !

    Jean-Philippe

  5. #5
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    SP4 for SQL 2K is not yet released, confirm the status.

    In your case AWE is not involved, so don't go further.

    Capture counters with the PERFMON as specified to assess the situation.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  6. #6
    Join Date
    Mar 2004
    Posts
    4

    Response

    Thnks for your response.

    So... Sorry.... It's not SP4 for SQL !!! Sorry again.
    It's SQL Service Pack 3a.

    So. I just configure the server in Non-dynamic allocation memory.
    The memory used bu SQL is 512 Mb
    I put the memory reserved for SQL to 512 Mb.
    My total memory on the server is 1Gb...

    What do you think about this ?
    Normally, I think, AWE is not implemented on this server. But befor I put the memory in static, i was in dynamic between 0Mb to 512Mb. I rebooted the server and I have the same mesage again !!! I don't understand.

    Sorry for my english but I'm french and, please, use a simple english !

    Thanks a lot again !

    CU
    Jean-Philippe.

  7. #7
    Join Date
    Mar 2004
    Posts
    4

    Others values

    It's me again !

    When i type "sp_configure" in request analyser, the system say in "AWE ENABLE" line Min : 0, Max : 1 and config value = 0

    So, I think that AWE is not used ? Correct ?

    So, if it's correct, what is the reason of my problem !?

    Thanks a lot again.
    Regards.

    Jean-Philippe

  8. #8
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    COnfirm the activity of database maintenance activities and try to reboot the box once to get to the level.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •