Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2003
    Posts
    9

    Unanswered: ORA-03106: fatal two-task

    Hi All,

    I have an error while working with DB links.The db link is looking at
    FS system from HR system. It It is working fine in one instance.
    It is not working and getting error (ORA-03106: fatal two-task
    communication protocol error) on other instance.

    Anybody have any Idea???

    This is the equivalent sql which i wrote in PeopleSoft SQR

    SELECT Chk_pyd.XX_WARRANT_AMT from PS_XX_FA_WARR_ACT@FSDEV Chk_pyd
    where Chk_pyd.FISCAL_YEAR = '2004'
    and Chk_pyd.XX_COLLEGE IN ('C','F')
    and Chk_pyd.XX_FUND = 'H1'
    and Chk_pyd.XX_warrant_dt < sysdate

  2. #2
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: ORA-03106: fatal two-task

    Originally posted by earanti
    Hi All,

    I have an error while working with DB links.The db link is looking at
    FS system from HR system. It It is working fine in one instance.
    It is not working and getting error (ORA-03106: fatal two-task
    communication protocol error) on other instance.

    Anybody have any Idea???

    This is the equivalent sql which i wrote in PeopleSoft SQR

    SELECT Chk_pyd.XX_WARRANT_AMT from PS_XX_FA_WARR_ACT@FSDEV Chk_pyd
    where Chk_pyd.FISCAL_YEAR = '2004'
    and Chk_pyd.XX_COLLEGE IN ('C','F')
    and Chk_pyd.XX_FUND = 'H1'
    and Chk_pyd.XX_warrant_dt < sysdate
    check for NLS incompatibilities between the server and client.
    then check enviroment variable TWO_TASK

  3. #3
    Join Date
    Aug 2003
    Posts
    9

    Re: ORA-03106: fatal two-task

    Originally posted by ika
    check for NLS incompatibilities between the server and client.
    then check enviroment variable TWO_TASK
    Still It does not work

  4. #4
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: ORA-03106: fatal two-task

    Originally posted by earanti
    Still It does not work
    What kind of value is in $TWO_TASK?
    Try: unset TWO_TASK

  5. #5
    Join Date
    Sep 2003
    Posts
    9
    Probably not much help but Ive seen this error only once.

    It was when i wrote some test code in php using pear. After much searching i found the error.

    Problem for me was that ORACLE_HOME needed to be set when apache was started. Doing this (just for test i put it in apache's startup script) it worked and the error dissapered.

    Just my 2 cp....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •