Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2004
    Location
    argentina
    Posts
    5

    Angry Unanswered: Connects but network error, I'm behind Wingate

    Hello.

    I'm trying to connect to SQL Server using Enterprise manager. I'm behind a Wingate proxy.

    I've configured an alias using TCP/IP, pointing to the (local network) IP of the Wingate box.

    On the Wingate box I've set a TCP Mapping service on port 1433, pointing to the IP of the remote SQL Server on port 1433 too.

    The error message is:
    General network error. Changed language settings to us-english. ConnectionRead(Error SIO_KEEPALIVE_VALS())..

    I assume at least *something* is right, as if I change the password to a bogus one I get "Login failed" instead of this network error.

    Hope someone can point me in the right direction. Thanks,
    - Manuel

  2. #2
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    You probably need to enable UDP port 1434 as well. See MSDN for a more complete explaination.

    -PatP

  3. #3
    Join Date
    Feb 2004
    Location
    argentina
    Posts
    5

    Red face not there yet...

    Hello.

    Just added UDP mapping on 1434. Same error.

    Read the MSDN article but couldn't figure what else to try. Just in case I didn't make myself clear, I'm trying to connect to a server outside my local network (as opposed to enabling a server on my network to be seen on the internet).

    How can I debug this forward? What else can I do?

    Thanks again,
    - Manuel

  4. #4
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    Check the Wingate log, and look to see what traffic is blocked from the workstation headed toward the server's IP address. It should be on port 1433 unless you are using a named instance of SQL Server, but look for anything, just in case.

    Triple check to be sure that your Client Network Settings and the server's Server Network Settings are compatible, especially if they are using a Proxy.

    -PatP

  5. #5
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    As referred by Pat ensure both client & server's netlibs are similar, by chance are you running on cluster?

    Try to use Named-pipes instead of Tcp/IP.

    Information about Orphaned sessions from this mSDN link.

    HTH
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •