Hi, all!
I have an Oracle Text knowledge base on server compiled for WE8ISO8859P1 characterset.
When I try to access it from Java-application with any statement like this:

select res_id from resources where contains(res_description, 'about(bla-bla-bla)')>0;

I get an error:

java.sql.SQLException: ORA-29902: error in executing ODCIIndexStart() routine
ORA-20000: Oracle Text error:
DRG-11432: file error while accessing knowledge base

When I execute the same statement from Windows-application like SQL Plus, all is OK.
This all is because of language mismatch on client-side and server-side. But how can I set language for Java-application?

I tried to set JVM system properties:
java -Duser.language=en -Duser.region=US -Dfile.encoding=Cp1252 ...
but it didn't help.

I tried to set NLS_LANG environment variable and connect through oci8 JDBC driver (instead of thin), but it didn't help too (I thought, it should...)

At last I changed Windows Regional Options to:
location - English(United States) (originally Russian)
default language - Endlish(United States) (originally Russian)
and all worked fine, but this is NOT a correct solution.

Please, advise how can I solve this problem without changing system settings
Thank you.