My OS is:
GNU/Linux Slackware
with kernel 2.4.22
and glibc 2.3.2.
I have problem installing db2 on that os.
error is:
failed dependencies:
libc.so.6(GLIBC_2.2) is needed by IBM_db2cliv81-8.1.0-0
IBM_db2msen81 >= 8.1.0-0 is needed by IBM_db2cliv81-8.1.0-0
/bin/sh is needed by IBM_db2cliv81-8.1.0-0
/bin/sh is needed by IBM_db2cliv81-8.1.0-0
/bin/sh is needed by IBM_db2cliv81-8.1.0-0
/bin/sh is needed by IBM_db2cliv81-8.1.0-0
and so on ....

I see that simbolic link libc.so.6 points to glibc 2.2.
Do I need glibc 2.2? Won't installation of glibc 2.2 cause instability
of my sistem (possibly crach)?

Sorry if somebody already assked same question .... I'm member
of this forum for one day ...

best regards,
[m]