Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2004
    Location
    Malaysia
    Posts
    17

    Post Unanswered: Microsoft SqlServer Desktop Engine Connection Problem

    i installed the MSDE2000A on server and i tried to connect from client machine through vb Application using connection string. Server anad client are in LAN. but Some systems able to connect and some systems are unable to connect.

    i am getting the error:

    "SqlServer does not exist or access denied "

    for non connected machines.

    the server is listening from these machines. but not connecting to MSDE.

    can anyone give me solution what may be the cause.
    --------------------
    P.L.N.Prasad varma

  2. #2
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Ensure the System DSN used and login must have required privileges to connect to SQL server.

    What is the authentication mode used?

    Try:
    1. Make sure the SQL server is on
    2. Ping the server machine
    3. Try connecting to the IP address rather than the server name

    Review information from this KBA for potential causes and resolve it.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  3. #3
    Join Date
    Mar 2004
    Location
    Malaysia
    Posts
    17
    i am using user authentication mode.
    i have set DISABLENETWORKPROTOCOLS=0
    i have done pinging through IP Address.
    i am able ping database.
    after doing all these test .. still getting same error....

    is there any other possibilities.....




    Originally posted by Satya
    Ensure the System DSN used and login must have required privileges to connect to SQL server.

    What is the authentication mode used?

    Try:
    1. Make sure the SQL server is on
    2. Ping the server machine
    3. Try connecting to the IP address rather than the server name

    Review information from this KBA for potential causes and resolve it.
    --------------------
    P.L.N.Prasad varma

  4. #4
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Review points listed in the knowledgebase article.

    i am using user authentication mode.
    SQL Server does have only 2 modes - Windows only or mixed. Which on e is yours?

    i have set DISABLENETWORKPROTOCOLS=0
    Don't know about this protocol in SQL, it should be named-pipes, TCP/ip or Multi-protocol. From Start---> programs --> goto MSSQLServer program group and select Server network utility and check for enabled protocols.
    i am able ping database.
    How can you do that in SQL???
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  5. #5
    Join Date
    Mar 2004
    Location
    Malaysia
    Posts
    17
    mine is MIXEDMODE.

    this is obtained by setting parameter SECURITYMODE=SQL

    i am sorry to tell u that i ping to database.

    not database... it is server.

    i am able to ping to server where i installed MSDE.




    Originally posted by Satya
    Review points listed in the knowledgebase article.


    SQL Server does have only 2 modes - Windows only or mixed. Which on e is yours?


    Don't know about this protocol in SQL, it should be named-pipes, TCP/ip or Multi-protocol. From Start---> programs --> goto MSSQLServer program group and select Server network utility and check for enabled protocols.

    How can you do that in SQL???
    --------------------
    P.L.N.Prasad varma

  6. #6
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    I'm probably being silly, but could you have installed SQL as a named server and tried to access it as a default (unnamed) server?

    -PatP

  7. #7
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Check for any h/w issues on server installed by referring to event viewer log.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •