Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2004
    Posts
    27

    Question Unanswered: Impersonate and Exchange Linked Server

    Hello,

    On my SQL Server 2000, I have successfully created a linked server to my Exchange 2000 server (located on the same physical computer). I can't send request and everything is fine.

    But now, I would like to apply the "Impersonate" setting. The big problem I've got is that Exchange doesn't use a login and password for the authentification but use the Windows credentials.

    I have try things like :
    login : <domain name>\<username> with the real password
    login : <username>@<internet domain name> with the real password
    but that doesn't work.


    I would like to know if there is a way to "impersonate" user log on the SQL Server when they try to use the linked server to Exchange Server.

    Thank a lot

    Felix Pageau
    fpageau@NOSPAM.str.ca



    Print | Copy URL of this post



    Expand All Collapse All

  2. #2
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    You can't map to windows account on linked server, try map it to sql login instead.

    Using Enterprise Manager you can check the impersonate checkbox while setting up LS.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  3. #3
    Join Date
    Jan 2004
    Posts
    27
    I know that I can map it to a sql account but I can't give any right to a SQL account in Exchange server. So this can't help me to map the sql to an other account in Exchange but thank a lot

    Felix Pageau
    fpageau@NOSPAM.str.ca

  4. #4
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    I would suggest to post/search for your query in Exchange newsgroups also for any reference.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •