Env: Sun Solaris 8, Informix 9.3

Hopefully someone can help me as I am no informix expert but have to use it regularly. I backed up databases using ontape -s, but when testing this by restoring I accidentally tried to restore (ontape -r) whilst informix was still running. This put out an error about not being able to warm restore the rootdbs. I realised from the warm restore message the database was up and shut it down before running ontape -r again. The restore completed and the server entered fast recovery mode. I shut down with onmode -ykF which went OK however I am now unable to restart.

I backed up my databases using ontape -s for a full (level 0) backup to a file.

TAPEDEV and LTAPEDEV set to the following in onconfig


The messaging I am getting is as follows
oninit -v outputs

$ oninit -v
Validating chunks...succeeded
Initialize Async Log Flusher...succeeded
Forking btree cleaner...succeeded
Initializing DBSPACETEMP list
$ Checking database partition index...FAILED
oninit: Fatal error in shared memory initialization

My online.log outputs

08:50:48 Event alarms enabled. ALARMPROG = '/LOCAL/informix/ids.93/inst1/etc/log_full.sh'
08:50:48 Booting Language <c> from module <>
08:50:48 Loading Module <CNULL>
08:50:48 Booting Language <builtin> from module <>
08:50:48 Loading Module <BUILTINNULL>
08:50:53 IBM Informix Dynamic Server Version 9.30.FC6X3b Software Serial Number RDS#N000000
08:50:53 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized.

08:50:53 Warning: Invalid (non-existent/blobspace/disabled) dbspace listed
in DBSPACETEMP: 'tempdbspace1'
08:50:53 Physical Recovery Started at Page(1:5412).
08:50:53 Physical Recovery Complete: 2832 Pages Examined 2832 Pages Restored.

08:50:53 Logical Recovery Started.
08:50:53 10 recovery worker threads will be started.
08:50:56 Logical Recovery has reached the transaction cleanup phase.
08:50:56 Logical Recovery Complete.
5 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks

08:50:57 IBM Informix Dynamic Server Stopped.

08:50:57 mt_shm_remove: WARNING: may not have removed all/correct segments

I have ignored the TEMPDBSPACE error as this has always been present, I didn't carry out this install and its' present in the rest of the logs from when it was working.

I have run ipcs and found some shared memory and semaphores still there after shutdown so I killed them manually but still get the same error.

Could it be that trying a cold restore with the database server running has corrupted something and if so it fixable??