Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2004
    Location
    Tamworth, Staffordshire, England
    Posts
    12

    Unanswered: HTML Export Fails in Crystal Reports 9

    I have been building a multi-language installer that uses Crystal Reports 9. Rather than using the merge modules, I have extracted the files from the v9.2 English, French, German, and Spanish merge modules and dropped them into my installer (built with InstallShield DevStudio 9).

    Unfortunately, not everything is working! I get an "Export Failed" error when I try to export a report to HTML. The normal export location and page range dialogs appear, but the progress appears and disappears without any files being written to the output directory (which is created).

    I have selected files as indicated by the HTML topic in RUNTIME.CHM, using the English DLLs as my base and adding language-specific resources where they are available (and I can figure out their names!).

    A full list of files is:-

    crdb_ado.dll, crtowords_en.dll, crxf_html.dll, crxf_pdf.dll, crxf_rtf.dll, crxf_wordw.dll, crxf_xls.dll, exlate32.dll, Implode.dll, querybuilder.dll, sscsdk80.dll, u2dapp.dll, u2ddisk.dll, u2dmapi.dll, u2dnotes.dll, u2dpost.dll, u2dvim.dll, u2fcompress.dll, u2fcr.dll, u2fodbc.dll, u2frdef.dll, u2frec.dll, u2fsepv.dll, u2ftext.dll, u2fxml.dll, u2l2000.dll, u2lcom.dll, u2ldts.dll, u2lexch.dll, u2lfinra.dll, and ufmanager.dll

    plus self-registering DLLs:-

    craxdrt9.dll, crqe.dll, crtslv.dll, crviewer9.dll, ExportModeller.dll, pageObjectModel.dll, ReportRenderer.dll, and webReporting.dll

    These are all installed into CommonFiles\Crystal Decisions\2.0\bin and registered where appropriate. I am also installing MFC 6.2 and VB5 runtime.

    Sorry for the massive detail!

    Thanks for any assistance or suggestions,

    David
    David Briggs
    Technology Director
    Vector Networks Ltd.

  2. #2
    Join Date
    Mar 2004
    Location
    Yorkshire
    Posts
    1

    Re: HTML Export Fails in Crystal Reports 9

    I have had the same problem but got round it by including or ensuring the following DLLs are in the package deployment wizard;

    crxf_html.dll
    reportrenderer.dll
    pageobjectmodel.dll
    webreporting.dll
    commonobjmodel.dll
    rptdefmodel.dll
    u2fcompress.dll
    datadefmodel.dll

    Basically I worked through the article at the following location.
    http://support.businessobjects.com/l...s/c2012421.asp

    Hope this helps,
    Andy

  3. #3
    Join Date
    Mar 2004
    Location
    Tamworth, Staffordshire, England
    Posts
    12
    Dear Andy,

    Thanks for the suggestions. I had not seen the knowledge base article. I was working mostly from RUNTIME.CHM. I was missing three files from my installer:-

    commonobjmodel.dll
    datadefmodel.dll
    rptdefmodel.dll

    However, if I add them post-install to the bin directory and register them, instead of getting an "Export failed" error, I get a host application crash. As we are running inside MMC, this is virtually impossible to trace.

    The KB article also hints that keycode.dll might be required, so I have copied this into bin and registered it as well. That did not make any obvious difference. MMC still crashes when I try to export to HTML. I do get the export progress dialog and a warning if a previous export has created the output directory, but I got both of those before.

    I don't understand the licensing. According to the documentation, we are covered by the "free runtime", but I suspect that I need to do something with regwiz/r3wizen/keycode. It is not clear what that might be.

    Any more ideas?

    David
    David Briggs
    Technology Director
    Vector Networks Ltd.

  4. #4
    Join Date
    Mar 2004
    Location
    Tamworth, Staffordshire, England
    Posts
    12
    Got it!

    I was installing GDIPLUS.DLL to the wrong location. I was putting it into my application install directory. I copied it into WINSYSDIR and your KB article suggests putting it into the bin directory.

    I deregistered keycode and took it out of the bin directory, and the exports are still working!

    Thanks for the pointers. I now have a working four-language Crystal runtime (famous last words $;-) well, I've tested English...

    David
    David Briggs
    Technology Director
    Vector Networks Ltd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •