Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2004

    Unanswered: DBCA problem (freebsd)

    hey folks

    i've gone thru brian's article of installing oracle 9i on freebsd 5.1 (but i'm on freebsd 5.2.1). all went well except few things. couldnt find workaround to recompile the kernel so i moved on with the installation. went all well, after executing & finishing the root script, i oui attempts to start 4 tools. dbca tool and the agent failed. now, the dbca (database configuration asistant tool) didnt start, i got out of memory error and long list of details (which i can paste here if needed, but basically starts with segmentation violation and etc..). i moved on, and the installation was complete. now i want to set the database via dbca tool but i cannot do it (well i dont know how). i went to the oracle home, i have it at:
    but typing 'dbca' wont start it...

    i know i dont have enough quite enough ram (192).... i've tried starting it with both the oracle user and the root user. with started x-win. the file is there but i get the message
    dirname: illegal option -- p
    usage: dirname path
    arch: not found
    jre was not found in /../bin///green_thread/jre

    any hints?

  2. #2
    Join Date
    Jun 2004

    Unhappy DBCA Invocation PB


    When invoking DBCA, this is what I get:
    at oracle.sysman.assistants.util.NetworkUtils.getOneL ocalListenerProtocolAddress( )
    at oracle.sysman.assistants.util.NetworkUtils.getOneL ocalListernetProtocolAddress(NetworkUtils.hava:196 2)
    at oracle.sysman.assistants.util.NetworkUtils.getOneL ocalListernetProtocolAddress(NetworkUtils.hava:195 4)
    at oracle.sysman.assistants.util.NetworkUtils.getOneL ocalListernetProtocolAddress(NetworkUtils.hava:194 6)
    at oracle.sysman.assistants.util.NetworkUtils.getOneL ocalListernetProtocolAddress(NetworkUtils.hava:186 3)
    at oracle.sysman.assistants.util.NetworkUtils.getLoca lListernerAddress(
    at oracle.sysman.assistants.util.NetworkUtils.getLoca lListenerAddresses(
    at oracle.sysman.assistants.util. NetworkUtils.needLocalListener( 12)
    at oracle.sysman.assistant.util.step.StepContext.setL istenersToUpdate(
    at oracle.sysman.assistants.dbca.Dbca.execute(Dbca.ja va:85)
    at oracle.sysman.assistants.dbca.Dbca.main( 161)
    Exception in thread "main"

    What is causing this DBCA invokation problem ?


    PS: I tried to reinstall, but I get the same PB.
    I installed Oracle 9i Database + PatchSet on Red Hat Linux Enterprise 3 (WS) -- Workstation Edition.

  3. #3
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    Does xclock work for you prior to invoking DBCA? If not, fix this first.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts