Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2004
    Posts
    2

    Unanswered: ORA-01078: failure in processing system parameters

    Hi! all
    i have installed oracle9i on winXP professional. At first, my database was working normally ,when i made few changes in parameter file like i wanted to enable archiving , but, database didn't respond to changes. so, i try to create SPfile , since, then it's showing an error

    ORA-01078: failure in processing system parameters
    LRM-00109: could not open parameter file 'D:\ORACLE\ORA92\DATABASE\INITORCL.ORA'

    And in Oradim.log file
    ORA-12638: Credential retrieval failed

    pls, somebody can suggest how to resolve this problem


    Thanks,
    alp

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >pls, somebody can suggest how to resolve this problem
    Replace the changed values with the original values.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    You made a change that Oracle doesn't recognize ...
    Put the parameter file back to it's original form...
    If you need to make changes and are not sure what you are doing,
    make them 1 AT A TIME and try to start the database. Once it fails,
    you know where your problem is

    Gregg

  4. #4
    Join Date
    Jul 2003
    Posts
    2,296
    you created an spfile, but your database is attempting to start using
    the pfile.

    you need to set the spfile parameter:

    PHP Code:
    platform@kod1>  show parameter spfile

    NAME                                 TYPE        VALUE
    ==================================== =========== ====================
    spfile                               string      ?/dbs/spfile@.ora 
    or just specify at startup:

    startup spfile=(location of spfile)
    Last edited by The_Duck; 03-23-04 at 18:08.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  5. #5
    Join Date
    Mar 2004
    Posts
    2

    ORA-01078: failure in processing system parameters

    thanks for the reply.

    Stll iam having sme problem. i am not sure whether spfile is created or not? there is no indication of spfile<sid>.ora file has been created not even in Ora_home\dbs.(the default location)

    Database is neither reading init.ora file nor spfile<sid>.ora, even i specified path while starting database.
    startup pfile='d:\oracle\admin\orcl\pfile\init.ora
    Even tried using Oradim utility to startup instanace.
    at the end, same error is displayed.

    ORA-01078: failure in processing system parameters

    when i issued this stmt
    show parameter file

    ORA-01034 Oracle not available

    while connecting to database
    conn sys/db as sysdba
    it's showing
    connected to an idle instance


    pls, anybody suggest me how to resolve this problem.
    Do i have to drop this database and recreate it?







    Originally posted by The_Duck
    you created an spfile, but your database is attempting to start using
    the pfile.

    you need to set the spfile parameter:

    PHP Code:
    platform@kod1>  show parameter spfile

    NAME                                 TYPE        VALUE
    ==================================== =========== ====================
    spfile                               string      ?/dbs/spfile@.ora 
    or just specify at startup:

    startup spfile=(location of spfile)

  6. #6
    Join Date
    Jan 2004
    Location
    India
    Posts
    113
    The problem I think is when u r referring to pfile the name of it should be
    Init<sid>.ora . By the way do u have one init<sid>.ora file or only init.ora file.
    In ur previous update u heve written pfile=......\init.ora
    which should not be. I hope u donot have an Ifile pointing to the init file.

    Spfile if created will get precedence over Init file but if u specify the pfile location at the startup command then it starts up the instance using pfile.
    > Set ORACLE_SID=<name of the instance>
    >sqlplus sys/password@instance as sysdba

    SQL>startup <location\Init<sid>.ora>


    If the above does not solve the problem then drop and recreate the instance using oradim utility.

    All the best,
    Kaushik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •