Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2004
    Posts
    7

    Unanswered: DSN Connetion error

    I made a site by using asp+access.

    When I use the system DSN, the site run in gear. But it doesn't work in user DSN mode. What can I do next?

    The following is a part codes of the site about connection the DSN:
    ---------------------
    <%Pid = Request.Cookies("Pid")
    SRNO=Request("sr")
    Set connTemp = Server.CreateObject("ADODB.Connection")
    connTemp.Open "shenrong","",""
    Set rsTemp = Server.CreateObject("ADODB.Recordset")
    sql = "Select * from product Where SRNo='"&SRNo&"'"
    rsTemp.Open sql,connTemp,1,1,1%>

    <style type="text/css"><!--
    .style1{
    font-family: Arial, Helvetica, sans-serif;
    font-size: 11px;}
    --></style><!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd"><html><head><title>Shenrong Accessorize</title></head>
    <body style="margin:0px"><center>
    <table width="560" border="0" cellspacing="0" cellpadding="0">
    <tr><td width="400" valign="middle">
    <div align="center"><img src="../products/<%=rsTemp("SRNo")%>.jpg" border="0"></div>
    </td><td width="20"> </td><td width="100">
    <span class="style1">SR No.: <%=rsTemp("SRNo")%><br>Description: <%=rsTemp("Descr")%><br><br><a href="plugin/mooop.asp?sr=<%=SRNo%>">
    <font color="#009900">Add To MOO</font></a></span></td><td width="20">
    </td></tr><%rsTemp.close
    connTemp.close%><tr><td> </td><td> </td><td> </td><td> </td></tr></table></center></body></html>

  2. #2
    Join Date
    Mar 2004
    Posts
    7
    Thank u

  3. #3
    Join Date
    Mar 2004
    Posts
    7
    rewrite
    connTemp.Open "DSN=shenrong;UID=;PSW=;"

    it can work in system DSN but not in user DSN

  4. #4
    Join Date
    Apr 2004
    Location
    Malaysia
    Posts
    1

    how to set up the DSN for ms access for the use of asp.net web matrix?

    Hi there..

    when im running the whole thing in localhost, there is no problem..problems started when the thing is uploaded to the server..
    every pages concerning with database cannot be loaded..
    help pls

    thanx a million

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •