Results 1 to 7 of 7
  1. #1
    Join Date
    Nov 2003
    Location
    Jakarta, Indonesia
    Posts
    32

    Unanswered: SQL5043N DIA3201E TCP/IP problem

    Hello,
    I run into some problem when my DB2 8.1.4a on Windows 2000 sp4 restarted after crashed.
    It seem the TCP/IP services wouldn't start. I goggled 'DIA3201E' but my search just show 1 link to a japanese site.
    Has anyone run to this problem ?

    -------------------------
    C:\db2start
    SQL5043N Support for one or more communications protocols failed to start succ
    ssfully. However, core database manager functionality started successfully.

    -------------------------
    db2diag.log:
    2004-03-26-10.03.00.890000 InstanceB2 Node:000
    PID:1408(db2syscs.exe) TID:1316 Appid:none
    common communication sqlcctcpconnmgr Probe:5

    DIA3201E The service name "db2c_DB2" specified in the database manager
    configuration file cannot be found in the TCP/IP services file.

    2004-03-26-10.03.01.906000 InstanceB2 Node:000
    PID:1408(db2syscs.exe) TID:1364 Appid:none
    base sys utilities DB2StartMain Probe:911

    ADM7513W Database manager has started.

    -------------------------
    I check C:\WINNT\system32\drivers\etc\services contains this line:
    db2c_DB2 50000/tcp

    -------------------------
    Regards,
    Adam Ac

  2. #2
    Join Date
    May 2002
    Location
    General Deheza, Cba, Arg.
    Posts
    276

    Re: SQL5043N DIA3201E TCP/IP problem

    Hi,

    Check the environment variable db2comm.
    Run the command db2set and look this variable.

  3. #3
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: SQL5043N DIA3201E TCP/IP problem

    If it is not set, you will have to say

    db2set DB2COMM=TCPIP

    HTH
    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  4. #4
    Join Date
    Nov 2003
    Location
    Jakarta, Indonesia
    Posts
    32

    Re: SQL5043N DIA3201E TCP/IP problem

    Originally posted by achiola
    Hi,

    Check the environment variable db2comm.
    Run the command db2set and look this variable.
    It's set to TCP/IP
    This happen on my devel server so i just do a db2move, uninstall, install, db2move again and voila....
    I do this cuz we are on a tight schedule so i must do what i know WILL succeed to save some time

    Thank everyone for replying
    Regards,
    Adam Ac

  5. #5
    Join Date
    Aug 2014
    Posts
    3

    DIA3201E The service name "db2c_DB2" specified in the database manager configuration

    Quote Originally Posted by adam_ac View Post
    It's set to TCP/IP
    This happen on my devel server so i just do a db2move, uninstall, install, db2move again and voila....
    I do this cuz we are on a tight schedule so i must do what i know WILL succeed to save some time

    Thank everyone for replying
    Hello,

    I am also facing same problem

    "DIA3201E The service name "db2c_DB2" specified in the database manager configuration file cannot be found in the TCP/IP services file "

    I check C:\WINNT\system32\drivers\etc\services contains this line:
    db2c_DB2 50000/tcp

    Moreover DB2COMM is set to TCP/IP.

    But getting the same error.

    As this is my production environment and I don't want to uninstall db2.

    Please suggest me some solution. Thanks!

  6. #6
    Join Date
    Jul 2013
    Location
    Moscow, Russia
    Posts
    666
    Provided Answers: 55
    Hi,

    It can happen if your
    Code:
    db2c_DB2 50000/tcp
    line is the last one in the services file and it's not followed by CR/LF symbol.
    Just add an empty line at the end of the services file and restart the db2 instance.

    BTW,
    TCP/IP is not correct value for DB2COMM variable. Set it to TCPIP.
    Regards,
    Mark.

  7. #7
    Join Date
    Aug 2014
    Posts
    3

    DIA3201E The service name "db2c_DB2" specified in the database manager configuration

    Hi,

    We used below command and application is working fine.

    db2 update dbm cfg using svcename 50000

    As you suggested adding one line after the db2c_DB2 50000/tcp will resolve this problem but i don't what is the use of this last extra line.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •