Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2003
    Posts
    6

    Unanswered: isql utility doesnt seem to work with -o param

    Hello,

    I am using NT and connecting to ASE remotely. I tried to use isql utility with -o parameter for the very first time from DOS-Prompt. I can succesfully connect to the server by using :

    isql -S<server> -U<user> -P<pwd>[B]

    But the -o parameter does not work correctly,such as :

    isql -S<server> -U<user> -P<pwd> -o <output>[B]

    After i run this command it doesnot connect and make me wait till forever to connect

    But when i check path C partition root i face that the ouyput file is created ,but its empty.

    Now, my question is :

    How will i be able to run this command succesfully and create output files.? Is this because of DOS-Prompt?

    And also can someone do me a favour : I need a good EDITOR and COMPILER to run ASE commands and i don't know where to find. Searched about that on internet , find some but couldn't be able to run them succesfully also on my NT server (e.g. isqlViewer)

  2. #2
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    Be sure to not omit the "go" in the last line of your input script

  3. #3
    Join Date
    Feb 2004
    Posts
    1
    And make sure you end the input file with a linefeed.

  4. #4
    Join Date
    Mar 2004
    Posts
    25
    If

    isql -S<server> -U<user> -P<pwd> -o <output>

    is the full command that you're using then what is happening is a side-effect of all the output is going into the file - the prompt will never appear, but you are connected and you can run queries.

    If you run this command, type in your command then type 'go' and then exit - your output file will have all of the output.

    If you are looking to run a sql process from an input file then you need to add the -i parameter to specify the input file.


    hope this helps...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •