Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2004
    Location
    Iowa
    Posts
    4

    Unanswered: System.Data.SqlClient.SqlException: Login failed for user 'NT AUTHORITY\ANONYMOUS LOG

    I have searched all the forums on this issue and tried the other options but nothing seems to work. I have an IIS server using asp.net to connect to a SQL database on a separate server which also happens to be a domain controller(i.e. no local accounts). I have tried changing the connection string, web.config, etc. but I still can't get connected. I believe the issue is with the SQL security but I'm not sure.

    IIs is set up for Integrated Windows Auth.

    Here is the web.config:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

    <!-- application specific settings -->
    <appSettings>
    <add key="connectionString" value="Data Source=VGISQL2;Initial Catalog=PaymentApplication;Integrated Security=SSPI;" />
    </appSettings>


    <system.web>

    <!-- DYNAMIC DEBUG COMPILATION
    Set compilation debug="true" to enable ASPX debugging. Otherwise, setting this value to
    false will improve runtime performance of this application.
    Set compilation debug="true" to insert debugging symbols (.pdb information)
    into the compiled page. Because this creates a larger file that executes
    more slowly, you should set this value to true only when debugging and to
    false at all other times. For more information, refer to the documentation about
    debugging ASP.NET files.
    -->
    <compilation
    defaultLanguage="c#"
    debug="true"
    />

    <!-- CUSTOM ERROR MESSAGES
    Set customErrors mode="On" or "RemoteOnly" to enable custom error messages, "Off" to disable.
    Add <error> tags for each of the errors you want to handle.

    "On" Always display custom (friendly) messages.
    "Off" Always display detailed ASP.NET error information.
    "RemoteOnly" Display custom (friendly) messages only to users not running
    on the local Web server. This setting is recommended for security purposes, so
    that you do not display application detail information to remote clients.
    -->
    <customErrors
    mode="Off"
    />

    <!-- AUTHENTICATION
    This section sets the authentication policies of the application. Possible modes are "Windows",
    "Forms", "Passport" and "None"

    "None" No authentication is performed.
    "Windows" IIS performs authentication (Basic, Digest, or Integrated Windows) according to
    its settings for the application. Anonymous access must be disabled in IIS.
    "Forms" You provide a custom form (Web page) for users to enter their credentials, and then
    you authenticate them in your application. A user credential token is stored in a cookie.
    "Passport" Authentication is performed via a centralized authentication service provided
    by Microsoft that offers a single logon and core profile services for member sites.
    -->
    <authentication mode="Windows" />

    <!-- AUTHORIZATION
    This section sets the authorization policies of the application. You can allow or deny access
    to application resources by user or role. Wildcards: "*" mean everyone, "?" means anonymous
    (unauthenticated) users.
    -->

    <authorization>
    <allow users="*" /> <!-- Allow all users -->
    <!-- <allow users="[comma separated list of users]"
    roles="[comma separated list of roles]"/>
    <deny users="[comma separated list of users]"
    roles="[comma separated list of roles]"/>
    -->
    </authorization>

    <!-- APPLICATION-LEVEL TRACE LOGGING
    Application-level tracing enables trace log output for every page within an application.
    Set trace enabled="true" to enable application trace logging. If pageOutput="true", the
    trace information will be displayed at the bottom of each page. Otherwise, you can view the
    application trace log by browsing the "trace.axd" page from your web application
    root.
    -->
    <trace
    enabled="true"
    requestLimit="10"
    pageOutput="false"
    traceMode="SortByTime"
    localOnly="false"
    />

    <!-- SESSION STATE SETTINGS
    By default ASP.NET uses cookies to identify which requests belong to a particular session.
    If cookies are not available, a session can be tracked by adding a session identifier to the URL.
    To disable cookies, set sessionState cookieless="true".
    -->
    <sessionState
    mode="InProc"
    stateConnectionString="tcpip=127.0.0.1:42424"
    sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    cookieless="false"
    timeout="20"
    />

    <!-- GLOBALIZATION
    This section sets the globalization settings of the application.
    -->
    <globalization
    requestEncoding="utf-8"
    responseEncoding="utf-8"
    />

    <!-- ADDED BY YURI -->
    <identity impersonate="true" />

    </system.web>

    </configuration>





    HELP!!!!!!!!!!!!!!

  2. #2
    Join Date
    Oct 2003
    Location
    Buenos Aires, Argentina
    Posts
    20
    Depending on how you are authenticating users, check out the identity matrix
    to see how you will be authenticating, and adjust accordingly.

    http://msdn.microsoft.com/library/de...SecNetAP05.asp
    ------------------------------------
    Thanx
    ------------------------------------
    http://www.iespana.es/greatavatar/FIRMA/firma.jpg

  3. #3
    Join Date
    Mar 2004
    Location
    Iowa
    Posts
    4
    I have done this. I am passing "name provided by user" which is the account "mydomain/administrator". This account is the same account as is running the SQL service, is added to the database as the db_owner, but yet I still get the error. Unfortunately I'm not a guru at SQL so I'm sure I'm missing something there.

  4. #4
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106
    Only TCP/IP protocol allows anonymous connections to SQL. Make sure u've appropriate protocols enabled both at the server and at the IIS. If u have only Named Pipes; and tryin to connect anonymously it won't work bcause named-pipes require authentication to windows prior to connecting to SQL. Also check that u can connect to SQL through Query-analyzer etc from the IIS to figure out where the problem resides.

  5. #5
    Join Date
    Mar 2004
    Location
    Iowa
    Posts
    4
    I have tcp/ip set up on both servers. ODBC can connect without issues. I can't get the ASP.net application to connect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •