Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2004
    Posts
    52

    Angry Unanswered: Date issue on reports

    Hi,

    I tried putting automatic fields on my report: insert...date & time

    This creates a textbox: '=Format(Date(),"Short Date")
    but it gives a '#name?' error.

    I can use '=now()', but I can't get it in the right format (dd/mm/yyyy).

    Does somebody know the cause of the error and the resolution?

    Thanks,

    Phil

  2. #2
    Join Date
    Mar 2004
    Location
    Adelaide, Australia
    Posts
    32
    What you have tried should work.

    In a text box control on a report, put this in "Control Source" property:

    =Format(Date(),"dd/mm/yyyy")

    Even this works;

    =Format(Date(),"Short Date")

    Try it again.

  3. #3
    Join Date
    Mar 2004
    Posts
    52
    I can't type in the text box, it says

    'The function you entered can't be used in this expr
    * You may have used a DoEvents, LBound, Ubound, Spc, or Tab function in an expression
    *You may have used an SQL aggregate function, such as count in a design grid or in a calculated control field'

  4. #4
    Join Date
    Mar 2004
    Location
    Adelaide, Australia
    Posts
    32
    Not sure how you are trying to do it, so I have attached an example showing that putting a formatted date in a text box in a report works.
    Attached Files Attached Files

  5. #5
    Join Date
    Mar 2004
    Posts
    52
    Thanks, but that's the way I did it... I only have the problem on a specific pc, with AC97.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •