Results 1 to 9 of 9

Thread: Export problem

  1. #1
    Join Date
    Jan 2004
    Location
    India
    Posts
    191

    Unanswered: Export problem

    Hi,
    While exporting data at user level i am getting the following error.
    Help will kindly appreciated;
    I also tried by running catexp.sql file

    EXP-00056: ORACLE error 942 encountered
    ORA-00942: table or view does not exist
    EXP-00000: Export terminated unsuccessfully
    Pagnint
    (No need to search web before posting new question)

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Just the same happened to me while trying to export Oracle 8 database using EXP.EXE that is part of Oracle 9 installation. Is this the case with you too?
    (Running Oracle 8 EXP.EXE to export data from Oracle 9 database goes just fine.)

    Therefore, I'd suggest you to use Oracle 8 EXP.EXE and there should be no problems

  3. #3
    Join Date
    Jan 2004
    Location
    India
    Posts
    191
    Hi,

    I am trying this in my local system. I have oracle 8.1.7.
    Is it causing problem bcoz i have oracle9i client install in my machine.
    Hoe to find the version of exp.exp file.


    Thanks.
    Parag
    Pagnint
    (No need to search web before posting new question)

  4. #4
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    The same thing over here ... Oracle 8.1.7 database, Oracle 9i client. You surely have two EXP.EXE's; to run the proper one, change the directory (or use full path to EXP.EXE) as you probably installed Ora8 first, and then Ora9 so the path system variable finds Ora9 EXP first.

    For example, when you run CMD (from Start - Run ...), write something like

    C:\> c:\oracle\ora817\bin\exp un/pw@db tables=blabla file=data.dmp

  5. #5
    Join Date
    Jan 2004
    Location
    India
    Posts
    191
    U are great man.. Thanks a lot, things work.

    One more other problem:
    I have done export from from oracle 9i server.
    When im trying to import dmp file to 8.1.7 it is throwing error.
    I read some where that, u can not import data from higer version to lower version.

    Do u know any easy method to do it

    Thanks,
    Pagnint
    (No need to search web before posting new question)

  6. #6
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    It bothers me too ... so far, I didn't find a way to solve this problem other than the one we already discussed (export data from Ora9 using EXP of Ora8).

    Sorry ...

  7. #7
    Join Date
    Jan 2004
    Location
    India
    Posts
    191
    Sorry some less information,
    error whcih i am getting imp-00010
    Problem is i can not run catexp7 on oracle 9i...(privilege problem).
    Pagnint
    (No need to search web before posting new question)

  8. #8
    Join Date
    Jan 2004
    Location
    India
    Posts
    191
    There is solution for this..
    Run older version catexp7 on oracle 9i
    then do export. Dump file create can be succefully imported in the lower version

    Thanks,
    Pagnint
    (No need to search web before posting new question)

  9. #9
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Great! Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •