Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2003
    Location
    SoCal
    Posts
    721

    Unanswered: MySQL Windows2k Service Fails "Access Denied"

    I've read a ton of posts about "Access Denied" errors, but they are related to connecting to the DB. My error occurs when I attempt to start the MySQL service itself. If I run the command "mysqld --console" from a command line, it works, but I can't seem to get it to run as a service. I have ensured it's running as the Local System account, and even forced it to run as the admin, and my own user name, and I get the same error each time. I have made the configuration file changes to c:\winnt\my.cnf but it doesn't seem to help.

    Any suggestions? Thanks!
    That which does not kill me postpones the inevitable.

  2. #2
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320
    Your my.cnf file must be located in c:\ not in c:\winnt\
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

  3. #3
    Join Date
    Jul 2003
    Location
    SoCal
    Posts
    721
    My computer is setup with W2k loading on my E: drive, so I've tried copying both my.cnf and my.ini in E:\, E:\WINNT, E:\WINNT\System32, and C:\

    When I attempt to start the service, with the config files located in all those directories, I still get the same error.
    That which does not kill me postpones the inevitable.

  4. #4
    Join Date
    Jul 2003
    Location
    SoCal
    Posts
    721
    I've also set the --basedir property in the command line, and made sure the tempdir option in the my.ini file was pointing to a valid folder, yet I still receive an "Access Denied" error starting the service.
    That which does not kill me postpones the inevitable.

  5. #5
    Join Date
    Jul 2003
    Location
    SoCal
    Posts
    721
    I reinstalled MySQL under C: and was able to get everything to work, but the lion's share of my drive space is on E:, so I'd like the data directory to be stored there.

    When I copy the contents of the data directory on C: to E:, and change the datadir property in my.ini (and even use --datadir=e:/mysql/data in the service command line) I get the error:

    Error 1067: The process terminated unexpectedly.

    I thought maybe I should let MySQL create the files in e:\mysql\data so I cleared the data directory out, and ran "mysqld-nt --console" with the config pointing the datadir property to e:/mysql/data. The initial files were created. I then copied the "mysql" and "test" folders from the c:\mysql\data folder over to e:\mysql\data and tried to run it, but I receive the same error.

    For some reason it doesn't like the data directory being anywhere but C:
    That which does not kill me postpones the inevitable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •