Results 1 to 5 of 5

Thread: PHP Install

  1. #1
    Join Date
    Feb 2004
    Location
    Irving, TX (Dallas, Fort Worth)
    Posts
    379

    Unanswered: PHP Install

    Installed latest PHP with Apache and getting these errors from Apache:

    Syntax error on line 136 of D:/Program Files/Apache2/conf/httpd.conf:
    Cannot load D:/Program Files/Apache2/php4apache.dll into server: One of the library files needed to run this application cannot be found.

    Lines are:

    136 LoadModule php4_module "d:/Program Files/Apache2/php4apache.dll"
    137 AddModule mod_php4.c
    138 AddType application/x-httpd-php .php

    I was on the IRC chat and did not get much help. I searched my system and it does not have the "mod_php4.c" file.

    I wondering if this is the problem?

    Anybody have any such experience?

  2. #2
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: PHP Install

    Originally posted by dbsupport4me
    Installed latest PHP with Apache and getting these errors from Apache:

    Syntax error on line 136 of D:/Program Files/Apache2/conf/httpd.conf:
    Cannot load D:/Program Files/Apache2/php4apache.dll into server: One of the library files needed to run this application cannot be found.

    Lines are:

    136 LoadModule php4_module "d:/Program Files/Apache2/php4apache.dll"
    137 AddModule mod_php4.c
    138 AddType application/x-httpd-php .php

    I was on the IRC chat and did not get much help. I searched my system and it does not have the "mod_php4.c" file.

    I wondering if this is the problem?

    Anybody have any such experience?
    Your problem is here :
    136 LoadModule php4_module "d:/Program Files/Apache2/php4apache.dll"

    Check if php4apache.dll exists in path which specified on line 136

  3. #3
    Join Date
    Feb 2004
    Location
    Irving, TX (Dallas, Fort Worth)
    Posts
    379

    Not the Problem

    ika,

    File definately exists, copied it there myself in the install process. That's why I'm scratching my head on this. Don't know what it thinks it needs now.

  4. #4
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: Not the Problem

    Originally posted by dbsupport4me
    ika,

    File definately exists, copied it there myself in the install process. That's why I'm scratching my head on this. Don't know what it thinks it needs now.
    Which user is owner of the apache process? If the owner is not Administrator then try check the filesystem premisions for that user (owner of apache process).

  5. #5
    Join Date
    Feb 2004
    Location
    Irving, TX (Dallas, Fort Worth)
    Posts
    379

    Which OS

    Quote Originally Posted by ika
    Which user is owner of the apache process? If the owner is not Administrator then try check the filesystem premisions for that user (owner of apache process).
    IKA,

    I think you are assuming I'm on XP or 2K, but I'm not, this machine runs 98, which does not differientiate on Admin rights for users, so all users have admin rights.

    DBS4M

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •