Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2004
    Posts
    124

    Unanswered: problem running ASP scripts

    I am having a terrible time finding the answer to the following problem. I have a virtual directory setup over a network share. I can access the pages fine, but when I try to run any ASP scripts that connect to an Access database, I get the following Microsoft JET error:

    "Disk or Network error"

    I've been trying to figure this out for almost a week without any luck. I can access the page okay, but as soon as I try and run the ASP script (submitting a form for example) I get the above error. I know the scripts work okay because I've tried on other servers running IIS and everything works. So, it has to be a problem with my IIS setup or something that I didn't configure right to run ASP scripts. Can anyone please help. I'm completely at a loss? I don't know what else to try?
    Thanks for any help.
    -Dman100-

  2. #2
    Join Date
    Mar 2003
    Location
    Atlanta, GA
    Posts
    191

    Re: problem running ASP scripts

    Have you checked the following MS KB article?

    http://support.microsoft.com/default...b;EN-US;251254

    Tim
    Tim

  3. #3
    Join Date
    Jan 2004
    Posts
    124
    Tim,

    Thank you for replying to my post.

    Yes, I did find that article and checked my system environment settings.

    This is what I had set for the system variables regarding the Temp folders:
    Temp = c:\winnt\temp
    TMP = c:\winnt\temp

    the article mentioned..."be certain to check the system environment settings rather than environment variables of the logged-on user. Also ensure that the IUSER anonymous IIS account has access to the temporary folder."

    I checked permissions and set the Internet Guest Account to have access to the temp folder with read and write access? Am I missing something else?

    I'm not sure if I have all the permissions set correctly? That is the only thing I can think of? Any ideas?

    Thanks again for your help. I really appreciate it.
    -Dman100-

  4. #4
    Join Date
    Jun 2003
    Location
    Ohio
    Posts
    108
    Usually when your ASP is connecting to different directories, it uses an IWAM login.

    Check to see if IWAM has permissions.

  5. #5
    Join Date
    Jan 2004
    Posts
    124
    Is there some online information that discusses how to setup the IWAM permissions? Now, I'm getting a login error...access forbidden? I know this is related to setting up permissions.
    Thanks for your help!
    -Dman100-

  6. #6
    Join Date
    Jun 2003
    Location
    Ohio
    Posts
    108
    Your IIS admin and windows/NT admin should be able to help you find these users.

    In the meantime, you can read up at:
    http://infosecuritymag.techtarget.co...curity.shtml#8

    Iwam is just a user like any other login.

    `Le

  7. #7
    Join Date
    Jan 2004
    Posts
    124
    Since I'm accessing the site directory over a mapped drive there isn't a IUSR_servername and IWAM_servername listed under the security permissions for the mapped folder.

    I can create a bogus IUSR_ and IWAM_ account on the workstation where the folder resides. Then add and set permissions for the bogus IUSR_ & IWAM_ accounts for the site folder.

    But, I can access the index.asp page. I just can't run any ASP scripts and connect to the DB. So, wouldn't that indicate that the permissions are okay from the default IUSR account setup on the IIS server that is accessing the mapped site folder? Or, do I still need to create bogus IUSR_ & IWAM_ accounts on the workstation where the folder resides to be able to run the ASP scripts and connect to the DB?

    Hope that makes sense? I appreciate the help.

    Thanks,
    -Dman100-

  8. #8
    Join Date
    Jun 2003
    Location
    Ohio
    Posts
    108
    I raelly don't know anymore than I ahve told you I am afraid. From my understanding, IWAM should already exist -- it should have been created when IIS was installed.

    I can tell you this though: You should never use drive letters. Always use the UNC path: \\servername\path


    Sorry I cannot be of more help. IWAM should put you in the right direction at this point.

    Good luck.

    `Le

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •