Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2004
    Posts
    2

    Unanswered: Error -25588 and ESQLC

    Greetings!

    I have a problem connecting from an ESQLC program to an Informix Dynamic Server 9.30 UC1 instance, running on SunOS 5.8:
    The esql program compiled ok, but it times out trying to connect to the database server, giving sqlcode = -25588 and sqlerrd[1] = 4. The associated error message is: The appl process cannot connect to the
    database server demo_on;

    Im mentioning that Im using for this the default demo server with minimal modifications to the onconfig file. The demo_on instance is using shared memory and all the built-in tools (dbaccess etc..)
    are able to connect.
    The sqlhosts file exists and the $INFORMIXSQLHOSTS variable points to it.
    Contents of sqlhosts:

    demo_on onipcshm calm on_servername
    demo_se seipcpip calm sqlexec

    Relevant onconfig settings:
    DBSERVERALIASES -- not set
    DBSERVERNAME demo_on
    NETTYPE ipcshm,1,50,CPU

    The Informix Client SDK is 2.81 FC1 (64bit)


    The environment has only the minimal stuff:

    INFORMIXSERVER = demo_on
    INFORMIXSQLHOSTS = /opt/informix/etc/sqlhosts
    INFORMIXDIR = /opt/informix - this variable is a little confusing to me: the same variable
    name is needed by both the Informix Database Server and the Client SDK, but they are installed in
    different directories. In my case, I make it to point to the ClientSDK install dir only when Im
    using the esql binary.

    Any help is greatly appreciated!

    Thanks,
    Dorel

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780

    Re: Error -25588 and ESQLC

    Originally posted by jjordache
    Greetings!

    I have a problem connecting from an ESQLC program to an Informix Dynamic Server 9.30 UC1 instance, running on SunOS 5.8:
    The esql program compiled ok, but it times out trying to connect to the database server, giving sqlcode = -25588 and sqlerrd[1] = 4. The associated error message is: The appl process cannot connect to the
    database server demo_on;

    Im mentioning that Im using for this the default demo server with minimal modifications to the onconfig file. The demo_on instance is using shared memory and all the built-in tools (dbaccess etc..)
    are able to connect.
    The sqlhosts file exists and the $INFORMIXSQLHOSTS variable points to it.
    Contents of sqlhosts:

    demo_on onipcshm calm on_servername
    demo_se seipcpip calm sqlexec

    Relevant onconfig settings:
    DBSERVERALIASES -- not set
    DBSERVERNAME demo_on
    NETTYPE ipcshm,1,50,CPU

    The Informix Client SDK is 2.81 FC1 (64bit)


    The environment has only the minimal stuff:

    INFORMIXSERVER = demo_on
    INFORMIXSQLHOSTS = /opt/informix/etc/sqlhosts
    INFORMIXDIR = /opt/informix - this variable is a little confusing to me: the same variable
    name is needed by both the Informix Database Server and the Client SDK, but they are installed in
    different directories. In my case, I make it to point to the ClientSDK install dir only when Im
    using the esql binary.

    Any help is greatly appreciated!

    Thanks,
    Dorel
    Hi,

    Please define DBSERVERALIAS=demo_se and check the connection.
    I think that the connection esipcpip should be esipcstr.

    Gustavo.

  3. #3
    Join Date
    Apr 2004
    Posts
    2

    Re: Error -25588 and ESQLC

    Originally posted by gurey
    Hi,

    Please define DBSERVERALIAS=demo_se and check the connection.
    I think that the connection esipcpip should be esipcstr.

    Gustavo.
    Thanks for the reply Gustavo!

    setting the DBSERVERALIAS option and the IPC type for demo_se didn't help...
    Any other ideas ?

    Dorel

  4. #4
    Join Date
    Apr 2004
    Location
    Brussels
    Posts
    57
    We have only 1 INFORMIXDIR.
    On our IDS7.31.UD2 & AIX 4.3 the Esql library is installed in $INFORMIXDIR/lib/esql.
    Further we use onsoctcp. Maybe this can help u ?
    Yves & Willy

  5. #5
    Join Date
    Dec 2004
    Posts
    1

    sharred memory fails on 9.40 64bit

    Hi,

    We found the same error when we installed the 64 bit 9.4 version of informix. The sqlhosts entry for onipcshm caused this error message and we were not able to connect. We then used onsoctcp and set the INFORMIXSERVER variable to use the onsoctcp connection and everything worked correctly.

    I was researching why shared mememory might not work when I found your thread.

    Thanks
    Larry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •