Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2004
    Posts
    19

    Unanswered: problem with PHPmailer....

    I have a very strange problem.

    I 'm using PHP mailer from my computer, I'm using Apache, PHP and MySQL.

    I have an smtp and pop mail as part of a hosting plan.

    The thing is that sometimes the e-mail is sent without problems, and somestimes I get this error:

    Message was not sentMailer Error: Language string failed to load: recipients_failedroberto@superbafle.com

    roberto@superbafle.com is the e-mail wich a would like to send the e-mail, of course this is an example, this e-mail is load from the form the user fills.

    Why is not constant ????

    Where do you think the problem resides ??

    is it a smtp problem ??
    Last edited by Mysticav; 04-20-04 at 03:45.

  2. #2
    Join Date
    Jan 2004
    Location
    India
    Posts
    168

    Re: problem with PHP mailer....

    Plz write down the code sample.

    Regards
    Rajesh

    Originally posted by Mysticav
    I have a very strange problem.

    I 'm using PHP mailer from my computer, I'm using Apache, PHP and MySQL.

    I have an smtp and pop mail as part of a hosting plan.

    The thing is that sometimes the e-mail is sent without problems, and somestimes I get this error:

    Message was not sentMailer Error: Language string failed to load: recipients_failedroberto@superbafle.com

    roberto@superbafle.com is the e-mail wich a would like to send the e-mail, of course this is an example, this e-mail is load from the form the user fills.

    Why is not constant ????

    Where do you think the problem resides ??

    is it a smtp problem ??

  3. #3
    Join Date
    Apr 2004
    Posts
    19

    Smile Here is the code...

    require("class.phpmailer.php");
    $mail = new PHPMailer();
    $mail->IsSMTP(); // telling the class to use SMTP
    $mail->Host = "smtp.??????.net"; // SMTP server
    $mail->IsHTML(true);
    $mail->Username = "?????@???????.net";
    $mail->Password = "*******";
    $mail->From = "???????@???????.net";
    $mail->AddAddress($imail);

    $mail->Subject = $message="This is a test";

    $mail->Body = $message="<HTML><BODY><font face='Verdana' size='-1'> This is a test </FONT></BODY></HTML>";

    $mail->WordWrap = 50;

    if(!$mail->Send())
    {
    echo "Message was not sent";
    echo "Mailer Error: " . $mail->ErrorInfo;
    }


    -----------------------------------------------------------------

    This is the code.

    Again. It works perfect. But sometimes, fails. For example, the last 2 hours I was doing a few tests without problems, But know, again, the error comes.

    Then, I wait one hour, and again starts working !!!!!


    By the way, I lived for 2 years in India,

    Delhi, Varanasi, and Pune.

    I loved it !!!

  4. #4
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482

    Re: Here is the code...

    Originally posted by Mysticav
    require("class.phpmailer.php");
    $mail = new PHPMailer();
    $mail->IsSMTP(); // telling the class to use SMTP
    $mail->Host = "smtp.??????.net"; // SMTP server
    $mail->IsHTML(true);
    $mail->Username = "?????@???????.net";
    $mail->Password = "*******";
    $mail->From = "???????@???????.net";
    $mail->AddAddress($imail);

    $mail->Subject = $message="This is a test";

    $mail->Body = $message="<HTML><BODY><font face='Verdana' size='-1'> This is a test </FONT></BODY></HTML>";

    $mail->WordWrap = 50;

    if(!$mail->Send())
    {
    echo "Message was not sent";
    echo "Mailer Error: " . $mail->ErrorInfo;
    }


    -----------------------------------------------------------------

    This is the code.

    Again. It works perfect. But sometimes, fails. For example, the last 2 hours I was doing a few tests without problems, But know, again, the error comes.

    Then, I wait one hour, and again starts working !!!!!


    By the way, I lived for 2 years in India,

    Delhi, Varanasi, and Pune.

    I loved it !!!
    Wahte about class.phpmailer.php code?

  5. #5
    Join Date
    Jan 2004
    Location
    India
    Posts
    168

    Re: Here is the code...

    Plz write down the code for class.phpmailer.php. So that we can have a look what you are doing in that.

    Regards
    Rajesh
    Originally posted by Mysticav
    require("class.phpmailer.php");
    $mail = new PHPMailer();
    $mail->IsSMTP(); // telling the class to use SMTP
    $mail->Host = "smtp.??????.net"; // SMTP server
    $mail->IsHTML(true);
    $mail->Username = "?????@???????.net";
    $mail->Password = "*******";
    $mail->From = "???????@???????.net";
    $mail->AddAddress($imail);

    $mail->Subject = $message="This is a test";

    $mail->Body = $message="<HTML><BODY><font face='Verdana' size='-1'> This is a test </FONT></BODY></HTML>";

    $mail->WordWrap = 50;

    if(!$mail->Send())
    {
    echo "Message was not sent";
    echo "Mailer Error: " . $mail->ErrorInfo;
    }


    -----------------------------------------------------------------

    This is the code.

    Again. It works perfect. But sometimes, fails. For example, the last 2 hours I was doing a few tests without problems, But know, again, the error comes.

    Then, I wait one hour, and again starts working !!!!!


    By the way, I lived for 2 years in India,

    Delhi, Varanasi, and Pune.

    I loved it !!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •