Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2004
    Location
    Boston MA
    Posts
    2

    Question Unanswered: Oracle Service Starting

    Hi,

    I am running Oracle 8.16 on Windows 2000 Server (i know this is nowhere near latest Oracle) I just moved from windows NT though. My issue is as follows.

    The Oracle Service reports as Starting and oradim continues to run. When I try to connect to the DB i get ORA-01034: ORACLE not available. If I use evrmgrl to stop and strat the db manually i can connect but the service still says Starting. If I kill oradim it says started but I can only connect if I stop and start the db using svrmgrl? I am not sure why this is happening I have reinstalled twice now. The alert log looks clear.

    Any help would be much appreciated.

    Oisin

  2. #2
    Join Date
    Mar 2004
    Location
    Berkshire, UK
    Posts
    186
    it sounds like the service is not passing the correct password when starting or it is refferencing the wrong pfile or the autostart is not set to true

    in the registry, under HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0

    check that
    ORA_ORCL_AUTOSTART = TRUE

    and
    ORA_ORCL_PFILE points to the correct file (use notepad to open the file and paste in the string)

    assuming your database sid is ORCL

    you can delete and recreate the service using
    oradim -delete -sid <SID>

    oradim -new -sid <SID> -intpwd <PASSWORD> -startmode auto -pfile c:\oracle\ora81\database\init<SID>.ora
    Last edited by robert xr4x4; 04-20-04 at 15:19.
    There are 10 types of people in the world, those that know Binary and those that don't.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •