Results 1 to 5 of 5

Thread: Error 7302

  1. #1
    Join Date
    Apr 2004
    Posts
    4

    Unanswered: Error 7302

    Hello All -

    I am getting the following error after I create a linked
    server using Enterprise Manager on an SQL2K machine:

    Error 7302: Could not create an instance of OLE DB
    provider 'SQLOLEDB' error trace [Non-interface error: CoCreate of DSO for SQLOLEDB returned 0x80004002].

    The linked server is created OK, this error comes up when
    trying to browse tables/views.

    I have ServicePack3.

    Thanks!

  2. #2
    Join Date
    Mar 2004
    Location
    West London
    Posts
    34
    Audrey

    What is the linked server type?

    J

  3. #3
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Make sure that the OLE DB
    provider 'SQLOLEDB file is registered correctly. Use RegSvr32.exe to register the Microsoft OLE DB provider for that provider. If the registration fails, reinstall your MDAC components. For more information about MDAC, refer to this Web site:

    http://microsoft.com/data/
    Here is registry key refers to the provider name :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ Providers\ProviderName
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  4. #4
    Join Date
    Apr 2004
    Posts
    4
    Originally posted by SQLSurfer
    Audrey

    What is the linked server type?

    J
    Linked server type is MSSQL2000.

  5. #5
    Join Date
    Apr 2004
    Posts
    4
    Originally posted by Satya
    Make sure that the OLE DB
    provider 'SQLOLEDB file is registered correctly. Use RegSvr32.exe to register the Microsoft OLE DB provider for that provider. If the registration fails, reinstall your MDAC components. For more information about MDAC, refer to this Web site:

    http://microsoft.com/data/
    Here is registry key refers to the provider name :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ Providers\ProviderName
    Registration passes correctly, but she does not help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •