Results 1 to 1 of 1
  1. #1
    Join Date
    Apr 2004
    Posts
    1

    Question Unanswered: Information Integrator and LOBs

    I have such question/situation:

    there is DB2 (8.1.5) server (called for example A) as data server
    and there is DB2(8.1.5) server (B) with Information Integrator(8.1.5) as join server

    Client connects to server B and work with database on A in fact.
    database on server A contains data only, and some tables contains BLOB columns.

    Client uses stored procedures that created on server B and there is such bug: stored procedure (that return resultset with BLOB) fails at second start, then succesfully run, and again fails and so on fails every second run

    procedure contains only simple select from table with BLOB column

    CREATE PROCEDURE MAILER.GetAttachmentByID ( Attachment_ID INTEGER )
    SPECIFIC MAILER.GetAttachmentByID
    DYNAMIC RESULT SETS 1
    LANGUAGE SQL
    P1: BEGIN
    DECLARE result1 RESULT_SET_LOCATOR VARYING;

    DECLARE cursorAttachments CURSOR WITH RETURN TO CALLER FOR
    SELECT ATTACHMENTID, ATTACHMENTNAME,Replicated, ATTACHMENT FROM MAILER.ATTACHMENTS
    WHERE ATTACHMENTID=Attachment_ID;

    OPEN cursorAttachments;
    END P1

    error:
    ERROR [560BD] [IBM][CLI Driver][DB2/NT] SQL1822N From data source "-423" unexpected error code "A". elements "func="block_fetch" msg=" SQL0423N ". SQLSTATE=560BD

    but if Client execute simple select with BLOB columns - there is no error
    Last edited by antony_87; 04-21-04 at 09:05.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •