Results 1 to 3 of 3
  1. #1
    Join Date
    May 2003
    Posts
    369

    Unanswered: sqlplus won't start on new oracle installation

    Hello gurus,

    I installed Oracle 9iR2 on Solaris 8 and cannot get sqlplus to start.
    I followed the installation guide from Oracle and the software and database installed without errors. I get the following message when I attempt to run sqlplus:

    sqlplus "/ AS SYSDBA"

    sqlplus: not be found

    How do I fix this? Thanks

    Scott

  2. #2
    Join Date
    May 2003
    Posts
    369

    think I fixed this- need to add to .profile

    I fixed it temporarily by running the script as root:

    . /usr/local/bin/oraenv

    This sets up ORACLE_SID and ORACLE_HOME environment variables for Oracle on Solaris. Anyone know how to set this in the .profile for Oracle users to allow access to SQLPLUS and other Oracle applications on Solaris 8 UNIX? Thanks

    Scott

  3. #3
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482
    Simple add the entries in each user .bash_profile with your own values:

    export ORACLE_SID=TEST1
    export ORACLE_BASE=/apps/oracle
    export ORACLE_ADMIN=${ORACLE_BASE}/admin/${ORACLE_SID}
    export ORACLE_HOME=${ORACLE_BASE}/product/920ee
    export TNS_ADMIN=${ORACLE_HOME}/network/admin
    export NLS_LANG=AMERICAN_AMERICA.UTF8
    export LD_LIBRARY_PATH=${ORACLE_HOME}/lib

    export PATH=/usr/bin:/usr/sbin:/bin:/usr/local/bin:/usr/X/bin:${ORACLE_HOME}/bin:.


    HTH

    clio_usa - OCP 8/8i/9i

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •