Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2003
    Posts
    30

    Unanswered: Import getting slower and slower

    Hi,

    we are using navicat to import Excel files to mysql. we have one problem for larger files like with 20000 rows or more. first the import is fast but after 1000 rows or so ist getting slower and slower.

    is there a parameter for setting a buffer size in mysql which could be responsible for this behaviour!

    Thanks

    Thorsten

  2. #2
    Join Date
    Apr 2004
    Location
    Europe->Sweden->Stockholm
    Posts
    71
    Have you turned off index updating while importing (I don't know if navicat does this for you)? Turning index updating off will probably make your import take closer to linear time...

    "ALTER TABLE tab DISABLE KEYS" turns off (non-unique) index updating for MyISAM tables. I don't know about InnoDB. If you are sure that you have no duplicates in the data you import it is probably faster to drop indices and re-create them after the import is done (if you import into empty tables at least).

    And yeah, don't forget to "ALTER TABLE tab ENABLE KEYS" after the import, if you have disabled them prior.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •