Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2004
    Posts
    7

    Unanswered: Encryption over the wire - ver 9.4

    Having problems configuring an encryted socket connection for Informix 9.4 running on HP-UX 11.11. I have the following in the sqlhosts :

    idealtcp2 onsoctcp bass sqlexec4 csm=ENCCSM

    The concsm.cfg file on the server contains :

    ENCCSM("/u/informix9.40/lib/csm/iencs09a.sl","cipher[des]")

    The concsm.cfg file on the PC contains :

    ENCCSM("C:\Program Files\informix\Connect\lib\client\csm\iencs09a.dll ","cipher[des]")

    The setnet32 contains : csm=ENCCSM in the options box.

    When I then try to configure the ODBC connection, I get the following message on the PC :

    [Informix][Informix ODBC Driver][Informix]CSS: error processing initilization string: C:\Program Files\Informix\Client-SDK/etc/concsm.cfg.

    And on the server, I get the following in the online.log :

    16:05:52 listener-thread: err = -14565: oserr = 0: errstr = : CSS: error reading data.

    16:05:52 listener-thread: err = -25580: oserr = 32: errstr = : System error occurred in network function. System error = 32.


    Any ideas ?

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Please test the following:

    In the file sqlhosts on HP-UX, the name of CSM, must be between "()".
    Examp. idealtcp2 onsoctcp bass sqlexec4 csm=(ENCCSM).

    In the setnet32 change to csm=(ENCCSM).

    Also, I think that, the space between "Program Files", may be a problem.

    In the file concsm.cfg, i have:
    ENCCSM("C:\Informix\lib\client\csm\iencs09a.dll"," mac[levels:high],cipher[all],switch[cipher:6,key:6]")
    And work fine.

    Gustavo.

  3. #3
    Join Date
    Feb 2004
    Posts
    7
    Thanks for the info, Gustavo - it turned out to be my PATH environment variable on my PC. I'd got a previous version of I-Connect installed which was taking priority!

    Richie

  4. #4
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi Richie,

    I remember that the Ibm-Informix Client SDK must be 2.81 TC2.

    Gustavo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •