Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2003
    Posts
    172

    Unanswered: prompted to refresh

    Anybody know how to remove the prompt to refresh a pivot table when it opens?

    I tried this registry change (listed for excel 2k) and modified the location from 9.0 to 11.0 but it didn't help:
    http://support.microsoft.com/default...d=kb;IT;248204

    TIA

  2. #2
    Join Date
    Dec 2003
    Location
    San Diego, CA
    Posts
    153
    Have you tried Application.DisplayAlerts = False?

    Smitty

  3. #3
    Join Date
    Dec 2003
    Posts
    172
    i think that will work on automation but what about if a user opens it manually? i tried alerts=false in workbook open but i think the security message fires before that

  4. #4
    Join Date
    Dec 2003
    Location
    San Diego, CA
    Posts
    153
    There's no getting around the Macro Security message if security is set to Medium or High. You can set the security to Low, but that's not advisable unless you've got a Virus Scan program running.

    A better plan is to get a Digital Certificate. The Microsoft Knowledge Base details the process pretty well.

    There are also ways to "force" users into enabling macros by setting all the sheets except a "dashboard" sheet to XLVeryHidden in the Workbook_Open event with an explanation that Macros must be enabled in order to access the worksheet.

    Similar to the Password required workbook I'm attaching.

    Hope that helps,

    Smitty
    Attached Files Attached Files

  5. #5
    Join Date
    Dec 2003
    Posts
    172
    Smitty,

    I get the prompt even on low. I have the certs no problem but I was wondering if this latest Excel prompt could even be disabled. For example some of the new security features (even the ones that have been around a while in XP) such as the Outlook object model guard prompt can't be turned off (even with a cert - in Outlook's case you have to install an MS Exchange form and registry hack.)

    Joe G

  6. #6
    Join Date
    Dec 2003
    Location
    San Diego, CA
    Posts
    153
    Wow, I can't think of what would be causing you to get the security prompt when the level is set to Low.

    Smitty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •