Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2004
    Posts
    2

    Angry Unanswered: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)'

    I've been working on this for 3 days now and have about had it. Can someone please help me!? I've installed 3 versions of MySQL from both rpm and binary. Currently working with the binary distro 'mysql-standard-4.1.1-alpha-pc-linux-i686'. No matter which version I get the same error messages:

    <snip>

    [root@localhost mysql_root]# ./bin/mysqld_safe --user=mysql &
    [1] 18876
    [root@localhost mysql_root]# Starting mysqld daemon with databases from /var/lib/mysql
    040426 21:15:05 mysqld ended

    [1]+ Done ./bin/safe_mysqld
    [root@localhost mysql_root]# ./bin/mysqladmin version
    ./bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/tmp/mysql.sock' exists!

    </snip>

    Some FAQ's:

    No, the mysqld is not running. (and as you can see, it won't start)
    No, the /tmp/mysql.sock file does not exist.
    Yes, I read the manual (too many times maybe?)
    O/S: Redhat AS

    Which log file would give me an idea of what's going on?

    I've installed MySQL many times over the years and have never had this much trouble before. I'm about to bag the whole thing and just install Oracle, which I think is just overkill (besides, it's HUGE!). Any suggestions?

    Thanks,

    -M

  2. #2
    Join Date
    Oct 2003
    Location
    Slovakia
    Posts
    482
    What the error log says? (Obviously you didn't read enough because documentation reffers to messages in error log when error has occured)

  3. #3
    Join Date
    Apr 2004
    Posts
    2
    The error log said nearly the same error that's why I didn't post it here.

    I have since solved the problem by compiling and installing from the source files and have not had any trouble. I guess sometimes you just have to start from scratch!

    -M

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •