Results 1 to 4 of 4

Thread: Load very slow

  1. #1
    Join Date
    Sep 2003
    Posts
    63

    Unanswered: Load very slow

    We are trying to load a table using 14GB delimited flat file.
    Its running for past 18 hours. No other users are connected to the database.

    The table resides on 6 logical node partitioned database using ver 8.1 and aix 5.2

    How do I see if there is any bottleneck?
    Is there any way to improve the load operation?

    Thanks,
    toby

  2. #2
    Join Date
    Feb 2004
    Location
    Copenhagen
    Posts
    220

    Question Errors?

    Hmmm.. I'm suspecting that maybe
    your Load statement is running into
    many errors and is busy writing these
    to the logfile. (anyway thats what
    happened to me several times.)

    Have you tried loadning with
    warningcount 1000 for example?

    HTH
    Kristian K. Hansen
    Project Supervisor
    National Board of Health

  3. #3
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Is there some reason why you are not using db2atld - Autoloader?

    Also, it usually better if you create the indexes after the load (unless you need an index or PK to check for uniqueness). If they already exist, drop the indexes and recreate them when you are finished with the load.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  4. #4
    Join Date
    Mar 2004
    Posts
    448
    load in version 8 works like autoloader in partitioned enviroment.
    correct me if I am wrong load infact implicitly called autoloader in DSP.
    take snapshot , also use load query , check the processes at the system
    level.

    regards,

    mujeeb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •