Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48

    Exclamation Unanswered: I can't start my backup server (I'm using ASE 11.5)

    I can't start my backup server (I'm using ASE 11.5)
    My connection may not be well configured.
    I don't know what to do.
    How can I fix that ?
    Can anyone help me please ?
    thanks in advance

    I executed some commands to check the current parameters and options :

    1> sp_configure "allow remote access",1
    2> go
    Parameter Name Default Memory Used Config Value
    Run Value
    ------------------------------ ----------- ----------- ------------
    allow remote access 1 0 1 1

    (1 row affected)
    Configuration option changed. The SQL Server need not be rebooted since the option is dynamic.
    (return status = 0)

    1> load database archivetest from "f:\sybase\backup\base\donact\backup\archive_sav.s ql"
    2> go
    Msg 7205, Level 17, State 2:
    Line 1:
    Can't open a connection to site 'SYB_BACKUP'. See the error log file in the SQL Server boot directory.

    1> exec syb_backup...sp_who
    2> go
    Msg 7218, Level 11, State 2:
    Line 1:
    Site 'syb_backup' not found in sysservers.

    1> use donact01
    2> go
    Msg 911, Level 11, State 2:
    Line 1:
    Attempt to locate entry in sysdatabases for database 'donact01' by name failed - no entry found under that name. Make sure that name is entered properly.

  2. #2
    Join Date
    Nov 2002
    Posts
    207
    Pls. post the output of sp_helpserver.

  3. #3
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48

    sp_helpserver

    1> sp_helpserver
    2> go
    name network_name
    security_mechanism
    status
    id
    ------------------------------ ------------------------------
    -----
    DONACT01_XP DONACT01_XP
    NULL
    timeouts, no net password encryption
    2

    SYB_BACKUP DONACT01_BS
    NULL
    timeouts, no net password encryption, rpc security model A
    1
    (return status = 0)

  4. #4
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48

    sp_helpdb

    archive 15910.0 MB sa 5
    Aug 08, 2002
    select into/bulkcopy/pllsort, trunc log on chkpt, not recovered, abort
    tran on log full, offline

    archivetest 5000.0 MB sa 9
    May 05, 2004
    don't recover, offline
    =>I created it with "for load" option

    donateur 17096.0 MB sa 7
    Aug 08, 2002
    select into/bulkcopy/pllsort, trunc log on chkpt, not recovered, abort
    tran on log full, offline

    donateur_bis 17096.0 MB sa 6
    Aug 08, 2002
    select into/bulkcopy/pllsort, trunc log on chkpt, not recovered, abort
    tran on log full, offline

    master 5.0 MB sa 1
    Jan 01, 1900
    no options set

    model 2.0 MB sa 3
    Jan 01, 1900
    no options set

    new_donateur 17096.0 MB sa 8
    Mar 05, 2003
    no options set

    sybsystemprocs 45.0 MB sa 4
    Aug 08, 2002
    trunc log on chkpt

    tempdb 2050.0 MB sa 2
    May 06, 2004
    select into/bulkcopy/pllsort


    (1 row affected)
    (return status = 0)
    Last edited by elitol; 05-06-04 at 10:46.

  5. #5
    Join Date
    Nov 2002
    Posts
    207
    Couple of more things to try...

    1. Entry in interfaces file for DONACT01_BS.
    2. Can you do isql to DONACT01_BS?

  6. #6
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    How can I know which port to use in order to connect my backup server ?
    I think I configured it wrong

  7. #7
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    To answer your question : no I can't start a connection to donact01_BS

    D:\>isql -Usa -P -S donact01_BS
    CT-LIBRARY error:
    ct_connect(): network packet layer: internal net library error: Net-Lib
    protocol driver call to connect two endpoints failed

  8. #8
    Join Date
    May 2004
    Location
    France
    Posts
    16
    look in the interfaces file ,

    just post the output : cat $SYBASE/interfaces

    if there is no entry you should write down one for Syb backup, as dataserver, and choose the number of port


    in your isql the parameter for servername (-SXXX) must be the same (upper case if in the interface file it's in uppercase and lower case if its lower case

    isql -Usa -SDONACT01_BS (and no space betwenn S and server name)


    hope it helps ;-)

  9. #9
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    Excuse me, I'm not an expert.
    Where do I send the command : cat $SYBASE/interfaces.

    This is what I get when I try to start the backup server with ASE.
    error1 :
    ct_cmd_alloc() : user api layer: The connection has been marked dead.

    error2 :
    ct_send(): user api layer: external error: This routine cannot be called because another command structure has results pending.

    last thing :
    this is the last line in the backup log:
    May 05 16:23:05 2004: Backup Server: 3.48.1.1: The Backup Server will go down immediately. Terminating sessions.

    thanks for helping me

  10. #10
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    About what you asked me to do :

    D:\>isql -Usa -Paaaaaa -SDONACT01_BS
    CT-LIBRARY error:
    ct_connect(): network packet layer: internal net library error: Net-Lib
    protocol driver call to connect two endpoints failed

  11. #11
    Join Date
    May 2004
    Posts
    5
    Your backup server is not running, does the BS log say anything more before the last line?
    What OS are you on?
    Are you using SQL.INI or a directory service for picking up the connection parameters?
    If SQL.INI, does it look right?

  12. #12
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    above last line in backup log :

    May 05 15:01:43 2004: Backup Server: 1.52.1.1: Backup Server terminating because of system shutdown
    May 05 15:01:43 2004: Backup Server: 3.48.1.1: The Backup Server will go down immediately. Terminating sessions.
    May 05 15:06:48 2004: Backup Server/11.5/P/PC Intel/Windows NT 4.00/1/OPT/Fri Sep 5 14:00:00 PDT 1997
    May 05 15:06:48 2004: Confidential property of Sybase, Inc.
    (c) Copyright Sybase, Inc. 1987, 1996
    All rights reserved.

    OS : Win NT 4.0
    Attached Files Attached Files

  13. #13
    Join Date
    May 2004
    Posts
    5
    That's a normal shutdown, start it up again!

    That is, go in "control panel"->"services" and start the backup server that should be listed there
    Last edited by BugEyes; 05-07-04 at 09:34.

  14. #14
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48
    yes it is listed but I can't start it.
    I've tried like 10 times.
    it doesn't work !!

    when sybase starts up, 2 applications don't start : xpsrvr.exe and bcksrvr.exe

    this causes a problem when I want to start my backup server.
    Last edited by elitol; 05-10-04 at 05:11.

  15. #15
    Join Date
    Apr 2004
    Location
    Paris
    Posts
    48

    Help !

    Please help me ! My work is running late !

    Thanks a lot !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •