Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2004
    Location
    Chicago
    Posts
    54

    Unanswered: Configure SQL server client

    Hi,
    I have installed MS SQL Server on a win XP and a MS SQL Server client on a win2000. I don’t know how to configure this client to access the server remotely.
    Any pointer?
    Thanks.
    I am very new to SQL Server.

  2. #2
    Join Date
    Apr 2004
    Location
    Kansas City, MO
    Posts
    734
    That's kind of a backward installation isn't it????

    On the client, you need to go open Enterprise Manager.
    Expand the Microsoft SQL Servers.
    Right-click on SQL Server Group and click New SQL Server Registration.
    When you get to the area that says "Available Servers", type in the name of the machine with the SQL Server.

    You should then be able to access it.
    MeanOldDBA
    derrickleggett@hotmail.com
    When life gives you a lemon, fire the DBA.

  3. #3
    Join Date
    Jan 2004
    Location
    Chicago
    Posts
    54
    Thanks.

    I tried and I always get:

    Login failed for “null”. Reason: not associated with a trusted SQL server connection.

    If I provide a user it would say: Login failed for “xxx”.

  4. #4
    Join Date
    Apr 2004
    Location
    Kansas City, MO
    Posts
    734
    Are you on a domain? If not, go to the sql server and set up a SQL Server username and password, giving it the access you want or grant MACHINENAME/username access to the SQL Server.


    If I provide a user it would say: Login failed for “xxx”.

    Was this a SQLServer username and password, or an NT username?
    MeanOldDBA
    derrickleggett@hotmail.com
    When life gives you a lemon, fire the DBA.

  5. #5
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Make sure you have the following Security Settings on your server.

    Note: Here, the Windows User is the local user account that is used to connect to your instance of SQL Server.

    1. Click "Start", point to "Settings",and then click "Control Panel".
    2. In "Control Panel", double-click "Administrative Tools".
    3. In "Administrative Tools", double-click "Local Security Policy".
    4. In the "Local Security Settings" window, in the left pane, expand
    "Local Policies", and then click "User Rights Assignments".

    Also you can use sql standard user to connect to the database. In this case make sure that your sql server authentication is set to mixed.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  6. #6
    Join Date
    Jan 2004
    Location
    Chicago
    Posts
    54
    >> In this case make sure that your sql server authentication is set to mixed

    How to do this?
    I am using SQL Server 2000 developer edition.
    Thanks.

  7. #7
    Join Date
    Dec 2003
    Posts
    22
    Its part of the set up procedure for SQL Server. You change in Enterprise Manager. Open EM on the box the server is on. It should already be configured/registered to access the server. Right click on server name and go to properties. Click on the Security tab. Under Authenication, select SQL Server and Windows. That's Mixed Mode, meaning it will allow Windows Authenication mode (obviously) as well as logins defined in the database.

    To define your own login to the DB, go to security in the expanding tree. Then click on Logins. Right click on the blank space in the right pane and select new Login. Type a name, and select SQL Server Authenication, then type a password. On the next tab (Server Roles), check the System Administrators box. Now click OK.

    Go back to your dev box. Open EM and do the registration process for the server using the username and password you just created.

    Let me know if any of this isn't clear. Its late on a Thursday, so its about time that stuff makes sense in my head, but when it makes it out, I end up confusing others to no end.

    Thanks,
    Tim C

  8. #8
    Join Date
    Jan 2004
    Location
    Chicago
    Posts
    54
    Thank you all!
    I got my client to talk to server following your instructions.
    Thanks Tim!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •