Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2004
    Location
    Boston, MA
    Posts
    3

    Unanswered: Slow Form performance with Access 2K

    Hello. Due to the nature of our environment, we're running a split Access 2K database over a network (e.g. both front and back ends on a shared drive). In most situations performance seems fine, but in a few circumstances we've noticed that performance on one form is VERY slow. The form executes a select statement from a linked table that returns about 60K records. Obviously some delay is to be expected given the number of rows being returned but in a couple situations, some workstations experience an abnormal delay (over 30 seconds in some cases). A different workstation on the same network opening the same form retrieves the data with a few second delay. The workstations are mixed Windows 2K and XP but that doesn't seem to make a difference (the workstations experiencing the delays are Win2K). I can't seem to locate the source of this slowdown and was wondering if anyone out there has experience with a similar situation. Any assistance would be most appreciated. Thanks very much!

  2. #2
    Join Date
    Jan 2004
    Location
    Boston, MA
    Posts
    3

    Figured it out

    After rebuilding the indexes on the source table and including 'Option Explicit' on the form getting the data, the performance was MUCH better. Didn't know the expicit option could make such a difference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •