Results 1 to 5 of 5
  1. #1
    Join Date
    May 2004
    Posts
    3

    Question Unanswered: Connection Caché - DB2 problem

    Hi,
    from win2k I am trying to call a remote procedure in a AS400 machine using
    ODBC. But I always get this error: " SQLState: (01000) NativeError: [0]
    Message: [IBM][Controlador de ODBC do Client Access Express (32 bits)]Suporte
    Dinâmico de Extensão desactivado." This means something like "Extension dynamic
    support disabled". And it doenst allow me to properlly execute the procedure.
    Do you know what the problem is?
    Thank you very much.

  2. #2
    Join Date
    Jan 2003
    Location
    Zutphen,Netherlands
    Posts
    256
    Did you enable 'Enable extended dynamic (package) support' in the DSN settings (see: configure option for Client Access ODBC DSN)
    Ties Blom
    Senior Application Developer BI
    Getronics Healthcare
    DB2,ORACLE,Powercenter,BusObj,Access,
    SQL, SQL server

  3. #3
    Join Date
    May 2004
    Posts
    3
    I am trying to access "INTPCS" library, and by default under the tab "Package" I let the "QGPL" library with the option you refer activated, as you might see on the attached image. I also tryed to define there the "INTPCS" library but it didnt work either. Is there any kind of related option on the AS400 server side? Could you tell me if I should define anything different under this tab? Thank you a lot.
    Attached Thumbnails Attached Thumbnails Enable extended dynamic (package) support.bmp  

  4. #4
    Join Date
    Jan 2003
    Location
    Zutphen,Netherlands
    Posts
    256
    I am using a newer client access version than you (I am on V5R2) , but can you choose the application that addresses the AS400 and enable the package usage? (use / or use/add)
    Ties Blom
    Senior Application Developer BI
    Getronics Healthcare
    DB2,ORACLE,Powercenter,BusObj,Access,
    SQL, SQL server

  5. #5
    Join Date
    May 2004
    Posts
    3
    Before trying your idea, I made a really dummy thing... Unticked that famous option, made a restart and tried it on... and it worked!!!

    Now I put back the option enabled, just as it is in the image and it stills working!!!
    I am very about this!! But if it is the solution...

    I really appreciate your help. Thank you very very much. Sergio.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •