Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2004
    Posts
    190

    Unanswered: Backup File Size Limit

    What would cause there to be a limit of 1 GiG on the backup file size of the db2 backup command. I issued the command 'db2 backup db records to /workspace'. I expected this command to create 1 backup file, however when the file reached 1G I got he message 'SQL2059W A device full warning was encountered on device "/workspace" '. Do you want to continue(c), terminate this device only(d), abort the utility(t) ? (c/d/t)' I answered 'c' and another 1G file was created, then the same message appeared. The same thing happened after I answered 'c' again.

    Does anyone have an idea of what maybe happening?

  2. #2
    Join Date
    Feb 2002
    Posts
    96
    You can set the 'file size limit' to unlimited. If your /workspace is not having enough space to accomodate the backup file, then obviously you will get an error.

    Still if you want to restrict each backup file to smaller sizes, you can use multiple directories, eg,'db2 backup db to /workspace/d1, /workspace/d2. /workspace/d3.....'

    Regards
    Prakash

  3. #3
    Join Date
    Apr 2004
    Posts
    190

    db2 value for 'file size limit'

    I don't see any config value that looks like 'file size limit'. What is the DB2 config value ?

    Quote Originally Posted by cgprakash
    You can set the 'file size limit' to unlimited. If your /workspace is not having enough space to accomodate the backup file, then obviously you will get an error.

    Still if you want to restrict each backup file to smaller sizes, you can use multiple directories, eg,'db2 backup db to /workspace/d1, /workspace/d2. /workspace/d3.....'

    Regards
    Prakash

  4. #4
    Join Date
    Feb 2002
    Posts
    96
    Its not a db2 config value. Its a Server side file system setting. So you should change ulimit value (and/or) /etc/security/limits file parameter. You should have root to do this. (i hope you are working on AIX).

  5. #5
    Join Date
    May 2004
    Posts
    8
    Hello,

    I came across this problem too. After changing the file-size limit for db2inst1 (or whatever the instance owner is) you need to bounce the instance for the change to take effect.

    Regards,
    Noel.

  6. #6
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    The backup file will be owned by the instance owner irrespective of who you invoke the command as ... So the file size limit should be 'ulimited' for the instance owner ...

    To know this , logon as instance owner and issue

    ulimit -a

    Check the value againt 'file size' parameter ... I remember the value is the number of 512 k blocks

    If the value is not 'unlimited', request you system admin to change this

    HTH

    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •