Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2004
    Location
    Cergy
    Posts
    65

    Question Unanswered: Error when I want to drop a column ?

    SQL> ALTER TABLE GAZBX811.ARTICLES
    2 DROP (DATEMODI);
    ALTER TABLE GAZBX811.ARTICLES
    *
    ERREUR à la ligne 1 :
    ORA-00406: param. COMPATIBLE doit être 8.1.0.0.0 ou plus


    SQL>

    Sorry but I have a french version. My client is Oracle 9.2

  2. #2
    Join Date
    Sep 2002
    Location
    UK
    Posts
    5,171
    Provided Answers: 1
    There is an Oracle system parameter called COMPATIBLE that is apparently set to a value lower than 8.1.0.0.0 on your database. This means that you can't do anything that was not valid prior to 8.1.0.0.0. The solution (assuming you are actually using a server of version 8.1.0.0.0 or higher) it to change the COMPATIBLE parameter to a higher value.

  3. #3
    Join Date
    Jan 2004
    Location
    Cergy
    Posts
    65
    Where ?
    in the orainit.ora ?

  4. #4
    Join Date
    Sep 2002
    Location
    UK
    Posts
    5,171
    Provided Answers: 1
    Yes, this is one for your DBA. Setting the parameter is described here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •