Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106

    Angry Unanswered: Problem accessing snapshot files over FTP


    Hi folks, i am trying an anonymous pull merge replication over VPN.
    Publisher and FTP server are the same machine(VPNSERVER).
    In the Snapshot configuration in the enterprise manager i have following parameters:
    Generate snapshot in following location \\VPNSERVER\D$\FTP
    FTP Server Name :VPNSERVER Port:21
    Client path to this folder from ftp root: /ftp/ may be wrong here.
    login: repl
    Ftp Server configuration is:
    FTP port no: 21
    Repl user has administrative rights
    When i run snapshot agent; SNAPSHOT.CAB is created in the following folder is created:
    \\vpnserver\d$\ftp\ftp\VPNSERVER_repl_repl\2004052 4164453

    When i run the the merge agent at subscriber:
    following error i recieve:

    The schema script '' could not be propagated to the subscriber.
    The process could not retrieve file 'VPNSERVER_repl_repl\20040524164453\snapshot.cab' from the FTP site 'VPNSERVER'.
    200 Type set to I.
    200 PORT Command successful.
    550 /d:/ftp/VPNSERVER_repl_repl/20040524164453/snapshot.cab: No such file.

    if i change the parameter "client path to this folder" i get error that the snapshot files are obsolete, run the snapshot again.
    I guess the problem is with the exact location of snapshot file, because when i run the agent i can see the user REPL in the Ftp-monitor and there is no problem with accessing SQL at the publisher.

    Any idea of what i a missing?
    Thanx in advance.

  2. #2
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106
    Guys, Puleeez help me out!

  3. #3
    Join Date
    Jan 2003
    Location
    Nottinghamshire, UK
    Posts
    364
    Hi

    Have U tried connecting remotely to the Subscriber (PCAnywhere etc) - opening internet explorer & trying to type the path to the FTP directory into the address bar ? - to see if you can browse it ?

    GW
    "Everything should be made as simple as possible, but not simpler." - Albert Einstein
    "Everything should be made as complex as possible, so I look Cleverer." - Application Developer

  4. #4
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106
    Hi, thanx for ur response.
    I am using PCANYWHERE to access subscriber, for that machine is on WAN. Since i am using VPN all the servers in the LAN are accessible and i can browse FTP from the subscriber; it takes me to the default folder FTP. As i mentioned earlier that i can see the user REPL activated in the ftp server monitoring tool when i start the merge agent at the subscriber.
    I guess that the problem is where we specify the location of the snapshot files. Since for each snapshot; the folder changes with the new date name at the ftp site. The parameter : CLIENT PATH TO THIS FOLDER FROM FTP ROOT.



    Howdy!

  5. #5
    Join Date
    Jan 2003
    Location
    Nottinghamshire, UK
    Posts
    364
    Are you Using Enerprise Manager to right Click on the Publication & look in properties - Snapshot Location

    Is this location exactly the same as you can browse to from the subscriber

    Drop a file in there to check that you don't have 2 seperate locations
    "Everything should be made as simple as possible, but not simpler." - Albert Einstein
    "Everything should be made as complex as possible, so I look Cleverer." - Application Developer

  6. #6
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106
    Hi.
    Yes, i am using EM.
    \\VPNSERVER\D$\FTP this is the snapshot location in properties.
    When snapshot agent is run the following folder is created:
    \\vpnserver\d$\ftp\ftp\VPNSERVER_repl_repl\2004052 4164453

    i can access ftp from the subscriber thru browser like this
    ftp://vpnserver

  7. #7
    Join Date
    Jan 2003
    Location
    Nottinghamshire, UK
    Posts
    364
    Not overly sure about the use of the administrative share D$ as opposed to a proper share

    Try creating a true share

    I've had problems with this before - usually getting security access from the subscriber agent and on occasion not having the subscriber pointing to the correct path.

    All I can remember doing is changing the publication FTP path & it coming right

    Take a deep Breath - Clear U'r mind & try again

    Good Luck

    GW
    "Everything should be made as simple as possible, but not simpler." - Albert Einstein
    "Everything should be made as complex as possible, so I look Cleverer." - Application Developer

  8. #8
    Join Date
    Feb 2004
    Location
    PAKISTAN
    Posts
    106
    Hi.
    550 /d:/ftp/VPNSERVER_repl_repl/20040524164453/snapshot.cab
    that was the error.


    At FTP server, the default folder for FTP user was configured as "d:\ftp".
    i changed it to "\\vpnserver\ftp"
    It's working now.
    Thanx for ur help.

    Howdy!

  9. #9
    Join Date
    Jan 2003
    Location
    Nottinghamshire, UK
    Posts
    364
    Yup I can see it know

    Sorry I did'nt spot it earlier

    Glad 2 hear U'r sorted

    GW
    "Everything should be made as simple as possible, but not simpler." - Albert Einstein
    "Everything should be made as complex as possible, so I look Cleverer." - Application Developer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •