Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2003
    Location
    India
    Posts
    33

    Unhappy Unanswered: ORA-00018 ---- urgent

    Hi all,
    I am using oracle 9i (release 2) in windows 2000 server. Appln development is in Java. Its in SHARE SERVER mode.

    I'm getting a java exception like the following ORA error code....

    java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
    ORA-00018: maximum number of sessions exceeded.

    Actually my session parameter is 170.

    My first question is Whether we can increase the sessions parameter to a hihger value to resove to error??? If so what is the maximum value for the session parameter? Any other parameters to be changed accounding to session parameter?

    and

    While querying v$session I'm getting around 170 sessions..
    But around 160 are inactive... so whether it will count in the session parameter value or not???

    pls advice me...

    thanks in advance..
    Papps...

  2. #2
    Join Date
    Nov 2002
    Posts
    833
    the inactive or idle sessions still count; if you want to get rid of them
    you can make use of the resource_limit=true parameter in your init.ora file
    and attach your users an appropriate idle or connect_time value

    or you have to increase to processes parameter in your init.ora; but it has an impact on your lisencing ...

  3. #3
    Join Date
    Dec 2003
    Location
    India
    Posts
    33

    space quota exceeded

    thanks boss.... I have set the resource_limit parameter to true and created a profile and set the connect_time and idle_time and made the rest unlimitted.

    Thus the max session problem was over...

    But when I tried to create a table its showing the following error.

    ERROR at line 1:
    ORA-01536: space quota exceeded for tablespace 'TS_XXX01'

    But the quota for the user is unlimited in that tablespace and tablespace is also having lot of freespace.... So which related parameter should I change while changing the user default profile or setting the resource_limit parameter...???

    Thanks in Advance...
    Papps...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •