Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    Join Date
    May 2004
    Posts
    5

    Red face Unanswered: newbie: ORA-01031: insufficient privileges (Linux)

    Hi,

    I'm trying to run Oracle 9.2 on SuSE 8.1 and I'm not sure how to start my
    instance.

    There isn't a SVRMGR program any more, but there is a DGMGRL program, that has options to 'startup', 'shutdown', etc. If I try 'connect internal' (when logged into the shell as either root or Oracle) it prompts me for a password. I've tried both my unix root and Oracle SYSTEM password here, and each time the program says 'ORA-09275: CONNECT INTERNAL is not a valid DBA connection'. It won't then let me use the 'startup' command.

    -----------------------
    'lsnrctl status' confirms the listener is running. It has entries like:

    Service "data2.JC" has 1 instance(s).
    Instance "data2", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully
    -----------------------
    When I start sqlplus from either the unix root user or Oracle user, it won't let
    me log on as '/ as sysdba'. (Same error for unix users root and Oracle)

    Enter user-name: / as sysdba
    ERROR:
    ORA-01031: insufficient privileges

    If I try to log on as SYSTEM, I get: (for both unix user root and Oracle)
    Enter user-name: SYSTEM@data2
    Enter password:
    ERROR:
    ORA-01034: ORACLE not available
    ORA-27101: shared memory realm does not exist
    Linux Error: 2: No such file or directory

    (If I change to an incorrect database name, such as data4, it says cannot
    resolve service name. If I put a wrong user or password in though, I get the
    same 01034 and 27101 error.)

    -----------------
    JC:/proc/sys/kernel # cat shmmax
    1073741824
    -----------------

    listener.ora

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = /opt/oracle/product/9.2)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = DB1.JC)
    (ORACLE_HOME = /opt/oracle/product/9.2)
    (SID_NAME = DB1)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = data2.JC)
    (ORACLE_HOME = /opt/oracle/product/9.2)
    (SID_NAME = data2)
    )
    )

    --------------------
    From oratab:

    DB1:/opt/oracle/product/9.2:Y
    data2:/opt/oracle/product/9.2:Y

    --------------------

    Any help would be appreciated.
    John_C

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    unset TWO_TASK
    Make sure ORACLE_SID & ORACLE_HOME are properly set.
    sqlplus
    / as sysdba
    startup
    exit
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    May 2004
    Posts
    5
    TWO_TASK isn't set
    ORACLE_SID was set to ORTD for some reason. Changed it to data2 in the profile.local file and rebooted.

    sqlplus
    connect / as sysdba
    still gives insufficient privileges from root user

    These errors still appear:
    Enter user-name: / as sysdba
    ERROR:
    ORA-01031: insufficient privileges

    If I try to log on as SYSTEM, I get: (for both unix user root and Oracle)
    Enter user-name: SYSTEM@data2
    Enter password:
    ERROR:
    ORA-01034: ORACLE not available
    ORA-27101: shared memory realm does not exist
    Linux Error: 2: No such file or directory

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    1) The only time the root account comes into play WRT Oracle is during the installation process; when you are directed to invoke $ORACLE_HOME/root.sh
    2) The use of @ALIAS in a connect string signifies to use SQL*Net;
    which is totally not needed when logged directly onto the DB server system.
    3) When you are logged onto a *nix box as the owner of the "oracle files"
    and your environmental variables are properly set, the following will work:
    sqlplus
    / as sysdba
    startup
    exit
    ===============================================
    http://download-west.oracle.com/docs...167_01/toc.htm
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Mar 2004
    Posts
    7

    DBA Group

    Make sure oracle or whatever owns the files is in the DBA group (as set up during install)

  6. #6
    Join Date
    May 2004
    Posts
    11
    You should not login as root, as anacedent mentionned.

    Also, what is the parameter REMOTE_LOGIN_PASSWORDFILE set at?

    Did you try re-creating the password file?

  7. #7
    Join Date
    May 2004
    Posts
    5
    Thanks for the help so far.

    REMOTE_LOGIN_PASSWORDFILE=EXCLUSIVE
    Haven't tried recreating pw file yet, not sure how to. Is it just a case of copying a new one from the default supplied?

    When I run dbastudio, it lets my oracle unix user log in as sysdba. When I choose to start the oracle instance, the information panel says "ORACLE not available". When I 'APPLY' to start up it says the familiar "ORA-10310 Insufficient Privileges". Also, when I try to look at either USERS or ROLES (under Security), I get an alert 'ORACLE not available'.

    When I try to start to 'NO MOUNT' stage, I get the same ORA-10310 error.

    I really suspect I've missed something very basic and might try a reinstall. It works immediately after an install, but fails after a reboot. On running dbastudio, the outut from 'ps' showed that the dbastudio process took up about 50 lines on the display!

    If anyone has any ideas, I'd be v grateful, but might just try reinstall, again!

    Thanks,
    John C

  8. #8
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >REMOTE_LOGIN_PASSWORDFILE=EXCLUSIVE
    try REMOTE_LOGIN_PASSWORDFILE=NONE
    ==================================
    GUIs can be EVIL
    I suggest only using SQL*Plus until you get things working.
    =============================================
    WTF?
    # oerr ora 10310
    10310, 00000, "trace synchronous change table trigger"
    // *Document: NO
    // *Cause:
    // *Action:
    =============================================
    Interesting "observation"......
    Metalink shows ZERO articles on the ORA-10310 error
    ==============================================
    Is there anything "interesting" in the alert_<SID>.log file?
    The bottom line is that you've done something squirrelly with the install.
    It is really not that hard to install Oracle on Linux & have it (re)start after a reboot.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  9. #9
    Join Date
    May 2004
    Posts
    5
    Thanks for the tips everyone. When I did a more conservative reinstall I knew a bit more about what parameters were doing what and where the problems might lie.

    I've still no idea what the initial problem was, but my simpler install involved:

    choosing DEDICATED server instead of SHARED
    not creating the database during installation
    CHANGED the memory setting TO typical and chose 50% of RAM

    Also worth noting is that the place to change $ORACLE_SID in my setup seems to be in the /etc/profile.local file.

    dbstart now starts my new database, data3. I've rebooted a few times and have managed to log on ok each time.


    Thanks again for the help everyone. I've no excuse for not studying toward my OCA now ;o)

  10. #10
    Join Date
    Sep 2009
    Posts
    2

    Possible cause

    I realise it is 5 years to late for the OP but for anyone else that happens accross this thread I have found a possible cause for the issue.

    In my case, the sqlnet.ora file (stored in the $ORACLE_HOME/network/admin directory) contained the following line:

    SQLNET.AUTHENTICATION_SERVICES= (NTS)

    by changing this line to:

    SQLNET.AUTHENTICATION_SERVICES= (ALL)

    I was once again able to authenticate onto the datbase using "/ as sysdba"

    Hope this helps.

  11. #11
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >SQLNET.AUTHENTICATION_SERVICES= (NTS)
    I am scratching my head over the response above.

    >>Specifies that Oracle is allowed to use NT native authentication to
    authenticate users.

    NT as in Windoze when this thread is about LINUX.
    I wonder how you got Windows sqlnet.ora on a Linux system.

    I am sincerely glad your problem got solved.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  12. #12
    Join Date
    Sep 2009
    Posts
    2
    Agreed.

    It might have just been a simple cut and paste mistake as we have Oracle servers on Linux and Windows.

    OR

    It might be that the people who installed oracle on the server before handing it over to me didn't really know what they were doing and simply took what worked from a Windows install and applied it to the Linux install.

    I'm not going to make judgements though, just posting what worked for me.

  13. #13
    Join Date
    Sep 2010
    Posts
    1
    I know that this thread is as old as the Universe itself, but I stumbled upon the exactly same problem. Oracle 11G R2, Ubuntu Lucid Lynx.


    Quote Originally Posted by anacedent View Post
    >SQLNET.AUTHENTICATION_SERVICES= (NTS)
    I am scratching my head over the response above.

    >>Specifies that Oracle is allowed to use NT native authentication to
    authenticate users.

    NT as in Windoze when this thread is about LINUX.
    I wonder how you got Windows sqlnet.ora on a Linux system.
    In my clean Oracle installation, I have SQLNET.AUTHENTICATION_SERVICES= (NTS) in my sqlnet.ora too.
    I don't know who put it there, but it definitely is there. In Oracle package for linux.
    Anyway, thanks for solution, guys.

  14. #14
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >I know that this thread is as old as the Universe itself, but I stumbled upon the exactly same problem. Oracle 11G R2, Ubuntu Lucid Lynx.
    >In my clean Oracle installation, I have SQLNET.AUTHENTICATION_SERVICES= (NTS) in my sqlnet.ora too.

    Interesting.
    I don't see what you report.

    Code:
    bcm@bcm-laptop:~$ cat /u01/app/oracle/product/11.2.0/dbhome_1/network/admin/sqlnet.ora
    # sqlnet.ora Network Configuration File: /u01/app/oracle/product/11.2.0/dbhome_1/network/admin/sqlnet.ora
    # Generated by Oracle configuration tools.
    
    NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)
    
    ADR_BASE = /u01/app/oracle
    
    trace_level_client = 16
    trace_unique_client = on
    trace_file_client = sqlnet.trc
    trace_directory_client =  $ORACLE_HOME/network/trace
    
    bcm@bcm-laptop:~$ uname -a
    Linux bcm-laptop 2.6.32-24-generic #43-Ubuntu SMP Thu Sep 16 14:58:24 UTC 2010 x86_64 GNU/Linux
    bcm@bcm-laptop:~$ sqlplus
    
    SQL*Plus: Release 11.2.0.1.0 Production on Tue Sep 21 17:22:25 2010
    
    Copyright (c) 1982, 2009, Oracle.  All rights reserved.
    
    Enter user-name: / as sysdba
    
    Connected to:
    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
    With the Partitioning, OLAP, Data Mining and Real Application Testing options
    
    SQL> select * from v$version;
    
    BANNER
    --------------------------------------------------------------------------------
    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
    PL/SQL Release 11.2.0.1.0 - Production
    CORE	11.2.0.1.0	Production
    TNS for Linux: Version 11.2.0.1.0 - Production
    NLSRTL Version 11.2.0.1.0 - Production
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  15. #15
    Join Date
    Jun 2010
    Posts
    81

    ubale to access SQLPLUS to restart instance

    Hi,

    I encountered a similar issue last night

    [oracle@basdwhdevdbl01 ~]$ sqlplus '/ as sysdba'

    SQL*Plus: Release 10.2.0.4.0 - Production on Wed Sep 22 06:16:16 2010

    Copyright (c) 1982, 2007, Oracle. All Rights Reserved.

    ERROR:
    ORA-01031: insufficient privileges


    Enter user-name:

    I need to be able to login to restart the instance - any ideas?

    The listener is currently running and this is on a Linux box

    Linux basdwhdevdbl01 2.6.18-92.el5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •