Results 1 to 4 of 4
  1. #1
    Join Date
    May 2004
    Posts
    2

    Unanswered: ERROR ORA-00942: table or view does not exist

    Hello,

    I have a oracle(9i) job set up to run every week and it is not running. I tried to run it
    manually and it gave me following error.
    ERROR at line 1:
    ORA-12011: execution of 1 jobs failed
    ORA-06512: at "SYS.DBMS_IJOB", line 406
    ORA-06512: at "SYS.DBMS_JOB", line 272
    ORA-06512: at line 1
    When I searched for this error in google, one of the answers i found said,that I have to grant SELECT ANY TABLE TO (USERNAME) system priviledge to the owner of the job. We granted this priviledge and then when i opened my toad and loged in with the (username). But when i click on the button to open schema browser window, it gives me ORA-00942: table or view does not exist error. I know that the tables and views are existing. Because if i login as user (system), i can change to (username) in toad and see the tables and views of that username. Can anyone help me with this please? ALso what priviledges should be given to the user to run a job?

    Thanks in advance.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Log into the database as the table owner.
    GRANT SELECT on <TABLE_NAME> TO <code_owner>;
    log into database as code owner & run job.
    Keep in mind that the code needs to look similar to the following:
    SELECT * FROM TABLE_OWNER.TABLE_NAME;
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    May 2004
    Posts
    2

    re

    The first thing is once i login to the database with (USERNAME),
    I am not able to see any tables or views or anything in the TOAD for that USER. As soon as i click the
    schema browser button, I get the error
    ORA-00942: table or view does not exist .
    Can you Please help me with this.

  4. #4
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    As of ORA-00942 in TOAD ... I'm not sure it'll help: do you perhaps have two Oracle instances installed on your PC? TOAD uses one of them to connect ("Connect using" ? ... which Oracle Home). So, maybe you're connecting to (let's say) Ora9 DB using Ora7 home which makes TOAD unable to run properly.
    Does it make any sense?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •